mbox series

[bug#57337,v2,0/2] Add docxbox

Message ID 20221226145732.1237-1-wz@freeshell.de
Headers show
Series Add docxbox | expand

Message

Wiktor Żelazny Dec. 26, 2022, 2:57 p.m. UTC
From: wzel <wzel@users.noreply.github.com>

Hi there,

Some pending issues:

1. For miniz-cpp, I tried and failed

    (arguments
     '(#:install-plan
       #~'(("zip_file.hpp" "include/")
 	   ("README.md" #$(string-append "share/doc/" name "-" version "/"))
      	   ("examples" #$(string-append "share/doc/" name "-" version "/")))))

, as this results in unknown gexp variable error.

2. For docxbox, I had to keep (package-source tinyxml2). This is
because, as I understand it, docxbox does not link to the compiled
library, and given my zero cmake experience I have no idea how to modify
the build process so that it does. Instead, it does what is described in
https://github.com/leethomason/tinyxml2 readme.md:

   TinyXML-2 is designed to be easy and fast to learn. It is one header
   and one cpp file. Simply add these to your project and off you go.

3. For docxbox, (file-name (git-file-name name version)) is not crashing
the build, anymore, but strangely during build --rounds=2 --check I
noticed four rounds taking place instead of two.

Thanks for taking a look,

WŻ

Wiktor Żelazny (2):
  gnu: Add miniz-cpp.
  gnu: Add docxbox.

 gnu/local.mk                                  |    1 +
 gnu/packages/cpp.scm                          |   35 +
 .../miniz-cpp-fixed-duplicated-symbols.patch  | 2734 +++++++++++++++++
 gnu/packages/textutils.scm                    |   76 +-
 4 files changed, 2845 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/miniz-cpp-fixed-duplicated-symbols.patch


base-commit: c50cd1bbece27097456242f246f89c053e7cc1a2