mbox series

[bug#59344,0/3] gnu: WIP Add cl-graph

Message ID 20221117234754.5396-1-sharlatanus@gmail.com
Headers show
Series gnu: WIP Add cl-graph | expand

Message

Sharlatan Hellseher Nov. 17, 2022, 11:47 p.m. UTC
Hi Guix team!

This patch series includes last inputs for cl-graph, but not cl-graph itself
as build phase failes with error:

> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
>                                                 {100B108083}>:
>   Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
> 
>     Permission denied

I've got WIP package in my personal repo
https://git.sr.ht/~hellseher/ffab/tree/main/item/ffab/packages/lisp-xyz.scm#L265,
I'll to figure out why it's failing, but if anyone may take a look it would be
great too!

> ./pre-inst-env guix build cl-asdf-system-connections cl-metacopy sbcl-cl-mathstats sbcl-asdf-system-connections sbcl-metacopy ecl-cl-mathstats ecl-asdf-system-connections ecl-cl-mathstats --rounds=2
> /gnu/store/0cj01ffnbhvrm8kaw4mi81xh92mv6v32-ecl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/jylgizsq3gv16024jfd54z71ygkbn10a-ecl-asdf-system-connections-0.8.4-1.9f08524
> /gnu/store/0cj01ffnbhvrm8kaw4mi81xh92mv6v32-ecl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/cg5iip9ncl345wxc9n34zpraswkznb8a-sbcl-metacopy-0.2.0-1.1b5bf44
> /gnu/store/lmmv8r7rzkfs7why6wlgbz9dg6rg4cf2-sbcl-asdf-system-connections-0.8.4-1.9f08524
> /gnu/store/lnq9a5rq4clfx7w6hvjwj14h7i7adqyi-sbcl-cl-mathstats-0.8.2-1.4df38ea
> /gnu/store/8k7hljl0fvk7qg23443sq4llsv7q6sy1-cl-metacopy-0.2.0-1.1b5bf44
> /gnu/store/s9vhj3sf645ydi9vadmjfbm79nwj07yi-cl-asdf-system-connections-0.8.4-1.9f08524

Sharlatan Hellseher (3):
  gnu: Add cl-asdf-system-connections
  gnu: Add cl-metacopy
  gnu: Add sbcl-cl-mathstats

 gnu/packages/lisp-xyz.scm | 94 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 94 insertions(+)


base-commit: 83c9e00ffbd41776c003f6992e9d613a5434fff9
prerequisite-patch-id: 679d60737b0daafbb9c5e2db480ac538b59d5889

Comments

Guillaume Le Vaillant Nov. 18, 2022, 1:43 p.m. UTC | #1
Sharlatan Hellseher <sharlatanus@gmail.com> skribis:

> Hi Guix team!
>
> This patch series includes last inputs for cl-graph, but not cl-graph itself
> as build phase failes with error:
>
>> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
>>                                                 {100B108083}>:
>>   Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
>> 
>>     Permission denied
>
> I've got WIP package in my personal repo
> https://git.sr.ht/~hellseher/ffab/tree/main/item/ffab/packages/lisp-xyz.scm#L265,
> I'll to figure out why it's failing, but if anyone may take a look it would be
> great too!

Patches 1 to 3 pushed as 89ebe054c5c32a6bb751548addda6fd31a27d099 and following.

Concerning cl-graph, it looks like it wants an optional subsystem of
cl-containers which is not compiled currently. Adding
cl-containers/with-moptilities and/or cl-containers/with-utilities and/or
cl-containers/with-variates to the 'asd-systems' argument in the package
definition of cl-containers should solve the issue.
Sharlatan Hellseher Nov. 18, 2022, 10:17 p.m. UTC | #2
Hi Guillaume,

Thanks for your pointing that out! It looks like I've fixed the build now:

> ./pre-inst-env guix build sbcl-cl-graph cl-graph sbcl-cl-containers cl-containers --rounds=2
> /gnu/store/xhcp5b79i332941219zdqh1pxnvbsvfp-cl-containers-0.12.1-4.3d1df53
> /gnu/store/iqbfp67yfa4dnkwq0fywfi84bmdgqcml-sbcl-cl-containers-0.12.1-4.3d1df53
> /gnu/store/nl7ykdxb1zzbq1qx387bd7iknay1s5h8-cl-graph-0.10.2-1.3cb7867
> /gnu/store/5r9jqnvr6nx4qhc37f3vda54am85ds07-sbcl-cl-graph-0.10.2-1.3cb7867

On Fri, 18 Nov 2022 at 13:51, Guillaume Le Vaillant <glv@posteo.net> wrote:
>
> Sharlatan Hellseher <sharlatanus@gmail.com> skribis:
>
> > Hi Guix team!
> >
> > This patch series includes last inputs for cl-graph, but not cl-graph itself
> > as build phase failes with error:
> >
> >> Unhandled SB-INT:SIMPLE-FILE-ERROR in thread #<SB-THREAD:THREAD "main thread" RUNNING
> >>                                                 {100B108083}>:
> >>   Error opening #P"/gnu/store/718rs4smnilaf2fhf4mqbxlkc4qicka3-sbcl-cl-containers-0.12.1-3.3d1df53/lib/common-lisp/sbcl/cl-containers/dev/utilities-integration-tmp1CXFJSK9.fasl":
> >>
> >>     Permission denied
> >
> > I've got WIP package in my personal repo
> > https://git.sr.ht/~hellseher/ffab/tree/main/item/ffab/packages/lisp-xyz.scm#L265,
> > I'll to figure out why it's failing, but if anyone may take a look it would be
> > great too!
>
> Patches 1 to 3 pushed as 89ebe054c5c32a6bb751548addda6fd31a27d099 and following.
>
> Concerning cl-graph, it looks like it wants an optional subsystem of
> cl-containers which is not compiled currently. Adding
> cl-containers/with-moptilities and/or cl-containers/with-utilities and/or
> cl-containers/with-variates to the 'asd-systems' argument in the package
> definition of cl-containers should solve the issue.