mbox series

[bug#59237,v2,0/5] Add LLVM/Clang 15.

Message ID 20221116141830.12398-1-maxim.cournoyer@gmail.com
Headers show
Series Add LLVM/Clang 15. | expand

Message

Maxim Cournoyer Nov. 16, 2022, 2:18 p.m. UTC
This v2 series includes the following changes the following changes, based on
Ludovic's review:

* Reduce code duplication via conditional changes to the the clang-from-llvm
  template procedure and inheritance.
* Add a libomp-15 package.
* Add a clang-toolchain-15 package.

Thanks!

Maxim Cournoyer (5):
  gnu: Add llvm-15.
  gnu: Add clang-runtime-15.
  gnu: Add clang-15.
  gnu: Add libomp-15.
  gnu: Add clang-toolchain-15.

 gnu/local.mk                                  |   1 +
 gnu/packages/llvm.scm                         | 288 +++++++++++++-----
 .../patches/clang-15.0-libc-search-path.patch |  95 ++++++
 3 files changed, 303 insertions(+), 81 deletions(-)
 create mode 100644 gnu/packages/patches/clang-15.0-libc-search-path.patch


base-commit: 5512915c3bd62e061bd47d440da02e0826c1d0e7

Comments

Ludovic Courtès Nov. 16, 2022, 3:21 p.m. UTC | #1
Hi Maxim,

Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:

> This v2 series includes the following changes the following changes, based on
> Ludovic's review:
>
> * Reduce code duplication via conditional changes to the the clang-from-llvm
>   template procedure and inheritance.
> * Add a libomp-15 package.
> * Add a clang-toolchain-15 package.

Perfect, LGTM!

Thanks,
Ludo’.
Maxim Cournoyer Nov. 16, 2022, 7:16 p.m. UTC | #2
Hello,

Ludovic Courtès <ludo@gnu.org> writes:

> Hi Maxim,
>
> Maxim Cournoyer <maxim.cournoyer@gmail.com> skribis:
>
>> This v2 series includes the following changes the following changes, based on
>> Ludovic's review:
>>
>> * Reduce code duplication via conditional changes to the the clang-from-llvm
>>   template procedure and inheritance.
>> * Add a libomp-15 package.
>> * Add a clang-toolchain-15 package.
>
> Perfect, LGTM!

Pushed with 83fb681658431362def447ec29876d565d49c9e5.