mbox series

[bug#59003,v2,0/6,Installer] Warn about unsupported devices

Message ID 20221109215637.22445-1-ludo@gnu.org
Headers show
Series Warn about unsupported devices | expand

Message

Ludovic Courtès Nov. 9, 2022, 9:56 p.m. UTC
Hi!

Here’s an updated version taking into account comments by
Florian and Mathieu.  Changes since v1:

  • Hardware-related bits moved to a new (gnu installer
    hardware) module.

  • The list in ‘%unsupported-linux-modules’ has been expanded
    using a manual method, as explained in the comment.  I’m
    open to improvements in this area :-), though I think this
    can come later.

  • Typos fixed.

Thoughts?

Ludo’.

Ludovic Courtès (6):
  installer: Warn about hardware support after the welcome page.
  linux-modules: Add support for listing PCI devices.
  linux-modules: Add 'load-pci-device-database'.
  installer: Use 'current-guix' for extensions.
  installer: Error page width is parameterized.
  installer: Report known-unsupported PCI devices.

 gnu/build/linux-modules.scm    | 135 ++++++++++++++++++++++++++++++++-
 gnu/installer.scm              |   8 +-
 gnu/installer/hardware.scm     |  90 ++++++++++++++++++++++
 gnu/installer/newt.scm         |   4 +-
 gnu/installer/newt/page.scm    |  12 +--
 gnu/installer/newt/welcome.scm | 111 +++++++++++++++++----------
 gnu/installer/record.scm       |   2 +-
 gnu/local.mk                   |   1 +
 po/guix/POTFILES.in            |   1 +
 9 files changed, 310 insertions(+), 54 deletions(-)
 create mode 100644 gnu/installer/hardware.scm


base-commit: d9ca9cdd01bf1097343a047b51a1392131c7cf58