mbox series

[bug#57337,0/2] Add docxbox

Message ID 20220822092753.31295-1-wz@freeshell.de
Headers show
Series Add docxbox | expand

Message

Wiktor Żelazny Aug. 22, 2022, 9:27 a.m. UTC
The docxbox patch is probably not ready for applying, yet (but it should
be close). This is my first attempt at “unvendoring”. The thing builds
and seems to work. The problem is that etc/ld.so.cache gets created. I
have no idea where it comes from, but I suspect that it shouldn’t be
there, as it’s easy to imagine a conflict if multiple packages with
etc/ld.so.cache are being installed.

miniz-cpp-fixed-duplicated-symbols.patch is the last commit in

   https://github.com/kstenschke/miniz-cpp/tree/patch-2

I think I just used `git show` and redirected the output to the file.
I’m noting this because I’m not sure if there are any potential
copyright issues involved in such a workflow.

I couldn’t get the test suite to work. Please, see the comment in the
package definition for the details.

Then, there are linter messages:

   /home/<USER>/guix/guix-git/gnu/packages/textutils.scm:1512:12: docxbox@0.0.5: the source file name should contain the package name

Adding the

   (file-name (git-file-name name version))

line removes the warning, but breaks the build.

   /home/<USER>/guix/guix-git/gnu/packages/textutils.scm:1512:12: docxbox@0.0.5: the source URI should not be an autogenerated tarball

I’m guessing this refers to GitHub Automatic Releases feature.
Unfortunately, there are no other releases to choose from in that
repository.

Finally, there’s the question related to the MS Word being proprietary
software. I don’t think there should be controversies here, as docxbox
is about interacting with the docx format, rather than the software
itself. And the format itself is standardized. Perhaps the synopsis
the package should avoid mentioning MS Word. I borrowed it from the
docxbox repository.

Wiktor Żelazny (2):
  gnu: Add miniz-cpp.
  gnu: Add docxbox.

 gnu/local.mk                                  |    1 +
 gnu/packages/cpp.scm                          |   27 +
 .../miniz-cpp-fixed-duplicated-symbols.patch  | 2734 +++++++++++++++++
 gnu/packages/textutils.scm                    |   73 +-
 4 files changed, 2833 insertions(+), 2 deletions(-)
 create mode 100644 gnu/packages/patches/miniz-cpp-fixed-duplicated-symbols.patch


base-commit: b8f2eb286ec52c97048e23d326d94ae5772797e8

Comments

Ludovic Courtès Sept. 8, 2022, 12:44 p.m. UTC | #1
Hi,

Wiktor Żelazny <wz@freeshell.de> skribis:

> The docxbox patch is probably not ready for applying, yet (but it should
> be close). This is my first attempt at “unvendoring”. The thing builds
> and seems to work. The problem is that etc/ld.so.cache gets created. I
> have no idea where it comes from, but I suspect that it shouldn’t be
> there, as it’s easy to imagine a conflict if multiple packages with
> etc/ld.so.cache are being installed.

That’s OK: every package gets this file; see
<https://guix.gnu.org/en/blog/2021/taming-the-stat-storm-with-a-loader-cache/>
for background.

> Then, there are linter messages:
>
>    /home/<USER>/guix/guix-git/gnu/packages/textutils.scm:1512:12: docxbox@0.0.5: the source file name should contain the package name
>
> Adding the
>
>    (file-name (git-file-name name version))
>
> line removes the warning, but breaks the build.

Weird, how so?  The name shouldn’t have any impact on the build process.
Could you investigate a bit?

>    /home/<USER>/guix/guix-git/gnu/packages/textutils.scm:1512:12: docxbox@0.0.5: the source URI should not be an autogenerated tarball
>
> I’m guessing this refers to GitHub Automatic Releases feature.
> Unfortunately, there are no other releases to choose from in that
> repository.

In that case, use ‘git-fetch’ instead of referring to the generated
tarball.

> Finally, there’s the question related to the MS Word being proprietary
> software. I don’t think there should be controversies here, as docxbox
> is about interacting with the docx format, rather than the software
> itself. And the format itself is standardized. Perhaps the synopsis
> the package should avoid mentioning MS Word. I borrowed it from the
> docxbox repository.

It’s OK to mention Word to say that the tool allows you to read its
files.

Thanks,
Ludo’.
Wiktor Żelazny Sept. 23, 2022, 6:21 p.m. UTC | #2
On Thu, Sep 08, 2022 at 02:44:06PM +0200, Ludovic Courtès wrote:
>
> Wiktor Żelazny <wz@freeshell.de> skribis:
>
> > The problem is that etc/ld.so.cache gets created. I
> > have no idea where it comes from,
>
> That’s OK: every package gets this file; see
> <https://guix.gnu.org/en/blog/2021/taming-the-stat-storm-with-a-loader-cache/>
> for background.

Very informative, thank you.

> > Adding the
> >
> >    (file-name (git-file-name name version))
> >
> > line removes the warning, but breaks the build.
>
> Could you investigate a bit?

This may be tough. But maybe the problem will go away by itself once the
package definition is rewritten.

> use ‘git-fetch’ instead of referring to the generated tarball.

OK!

Have a nice weekend,

WŻ