mbox series

[bug#57168,00/14] Add a LightDM service.

Message ID 20220813065006.27151-1-maxim.cournoyer@gmail.com
Headers show
Series Add a LightDM service. | expand

Message

Maxim Cournoyer Aug. 13, 2022, 6:50 a.m. UTC
Hello Guix!

This adds a lightdm-service-type, which is based on the work of 'L p R n d n'
more than two years ago.  It reworks the way configurations are define (via
define-configuration), exposes VNC and XDMCP configuration options and adds
unit and system tests.

It works fine, but there are a few gotchas:

1. The session selection menu doesn't show the items.  I don't know why.
Perhaps a regresssion with newer GTK+.

2. Because of 1., you should specify a default session, otherwise you won't be
able to log in, as the default session is 'default.desktop', which doesn't
exist.

Thanks,

Maxim Cournoyer (14):
  services: configuration: Add a 'maybe-value-set?' procedure.
  gnu: accountsservice: Update to 22.08.8, enable doc and test suite.
  gnu: accountsservice: Provide a means to locate extensions.
  gnu: lightdm-gtk-greeter: Add GDK_PIXBUF_MODULE_FILE to wrapper.
  gnu: lightdm-gtk-greeter: Use the glib-or-gtk-wrap phase as-is.
  gnu: lightdm-gtk-greeter: Enable libklavier support.
  gnu: lightdm-gtk-greeter: Adjust default config file path.
  gnu: lightdm-gtk-greeter: Adjust --enable-at-spi-command value.
  gnu: lightdm: Apply patch to fix a problem with VNC integration.
  gnu: lightdm: Apply patch to allow using VNC options.
  gnu: lightdm: Apply patch to fix color depth issue with VNC.
  marionette: Improve the error message of 'wait-for-screen-text'.
  build: marionette: Add support for Tesseract OCR.
  services: Add lightdm-service-type.

 Makefile.am                                   |   1 +
 doc/guix.texi                                 | 209 +++++-
 gnu/build/marionette.scm                      |  79 +-
 gnu/local.mk                                  |   5 +
 gnu/packages/display-managers.scm             |  83 ++-
 gnu/packages/freedesktop.scm                  |  93 ++-
 .../patches/accountsservice-extensions.patch  |  25 +
 .../patches/lightdm-arguments-ordering.patch  |  54 ++
 .../patches/lightdm-vnc-color-depth.patch     |  81 +++
 .../patches/lightdm-vncserver-check.patch     |  66 ++
 gnu/services/configuration.scm                |   5 +
 gnu/services/lightdm.scm                      | 687 ++++++++++++++++++
 gnu/tests/base.scm                            |   4 +-
 gnu/tests/install.scm                         |   8 +-
 gnu/tests/lightdm.scm                         | 161 ++++
 tests/services/lightdm.scm                    |  52 ++
 16 files changed, 1508 insertions(+), 105 deletions(-)
 create mode 100644 gnu/packages/patches/accountsservice-extensions.patch
 create mode 100644 gnu/packages/patches/lightdm-arguments-ordering.patch
 create mode 100644 gnu/packages/patches/lightdm-vnc-color-depth.patch
 create mode 100644 gnu/packages/patches/lightdm-vncserver-check.patch
 create mode 100644 gnu/services/lightdm.scm
 create mode 100644 gnu/tests/lightdm.scm
 create mode 100644 tests/services/lightdm.scm