mbox series

[bug#56426,0/6] Add Julia CSV

Message ID 20220706180537.406140-1-zimon.toutoune@gmail.com
Headers show
Series Add Julia CSV | expand

Message

Simon Tournier July 6, 2022, 6:05 p.m. UTC
Hi,

This series adds Julia CSV reader/writer.  Well, 'CSV.Chunks' fails so then
the 2 related tests.  I have no clue what could be wrong.  Therefore, I have
disabled these two ones.

I am currently checking some packages for i686-linux but the issues, if any,
can be addressed later.  Having the feedback from the build will help.


Cheers,
simon



zimoun (6):
  gnu: julia-parsers: Update to 2.2.4.
  gnu: Add julia-inlinestrings.
  gnu: julia-json: Update to 0.21.3.
  gnu: julia-weakrefstrings: Update to 1.4.0.
  gnu: Add julia-sentinelarrays.
  gnu: Add julia-csv.

 gnu/packages/julia-xyz.scm | 103 ++++++++++++++++++++++++++++++++++---
 1 file changed, 97 insertions(+), 6 deletions(-)


base-commit: 111bdcff48902457a7218f7ef8a80ad3dfaac3d1

Comments

Simon Tournier July 8, 2022, 7:51 a.m. UTC | #1
Hi,

On Wed, 06 Jul 2022 at 20:05, zimoun <zimon.toutoune@gmail.com> wrote:

> This series adds Julia CSV reader/writer.  Well, 'CSV.Chunks' fails so then
> the 2 related tests.  I have no clue what could be wrong.  Therefore, I have
> disabled these two ones.

Well, I have no clue why CVS.Chunks fails:

--8<---------------cut here---------------start------------->8---
 :col1  PosLenStringCSV.File basics: Error During Test at
/gnu/store/…-julia-csv-0.10.4/share/julia/loadpath/CSV/test/basics.jl:20
  Got exception outside of a @test
  ArgumentError: unable to iterate chunks from input file source
  Stacktrace:
    [1] CSV.Chunks(source::String; header::Int64, normalizenames::Bool, datarow::Int64, skipto::Int64,
footerskip::Int64, transpose::Bool, comment::Nothing, ignoreemptyrows::Bool, ignoreemptylines::Nothing,
select::Nothing, drop::Nothing, limit::Nothing, buffer_in_memory::Bool, ntasks::Nothing, tasks::Nothing,
rows_to_check::Int64, lines_to_check::Nothing, missingstrings::Vector{String}, missingstring::String,
delim::Nothing, ignorerepeated::Bool, quoted::Bool, quotechar::Char, openquotechar::Nothing,
closequotechar::Nothing, escapechar::Char, dateformat::Nothing, dateformats::Nothing, decimal::UInt8,
truestrings::Vector{String}, falsestrings::Vector{String}, stripwhitespace::Bool, type::Nothing, types::Nothing,
typemap::Dict{Type, Type}, pool::Tuple{Float64, Int64}, downcast::Bool, lazystrings::Bool,
stringtype::Type{PosLenString}, strict::Bool, silencewarnings::Bool, maxwarnings::Int64, debug::Bool,
parsingdebug::Bool, validate::Bool)
      @ CSV /gnu/store/…-julia-csv-0.10.4/share/julia/loadpath/CSV/src/chunks.jl:81
    [2] macro expansion
      @ /gnu/store/…-julia-csv-0.10.4/share/julia/loadpath/CSV/test/basics.jl:510 [inlined]
--8<---------------cut here---------------end--------------->8---

because it just reads:

--8<---------------cut here---------------start------------->8---
510: chunks = CSV.Chunks(joinpath(dir, "promotions.csv"); stringtype=PosLenString)
511: @test sum(length, chunks) == 10000
512: @test Tables.partitions(chunks) === chunks
--8<---------------cut here---------------end--------------->8---

Well, these 3 lines and 2 tests are thus bypassed over the thousands of
other tests. :-)


> I am currently checking some packages for i686-linux but the issues, if any,
> can be addressed later.  Having the feedback from the build will help.

Well, the current situation of i686 is bad [1,2] but unrelated to this
patch series.  Let merge this series which is perfectly fine for x86_64
and then fix the other arch as i686.

1: <https://ci.guix.gnu.org/build/1089455/details>
2: <https://ci.guix.gnu.org/build/1089455/log/raw>


Cheers,
simon
Efraim Flashner July 11, 2022, 10:08 a.m. UTC | #2
On Wed, Jul 06, 2022 at 08:05:37PM +0200, zimoun wrote:
> Hi,
> 
> This series adds Julia CSV reader/writer.  Well, 'CSV.Chunks' fails so then
> the 2 related tests.  I have no clue what could be wrong.  Therefore, I have
> disabled these two ones.
> 
> I am currently checking some packages for i686-linux but the issues, if any,
> can be addressed later.  Having the feedback from the build will help.
> 
> 
> Cheers,
> simon
> 
> 
> 
> zimoun (6):
>   gnu: julia-parsers: Update to 2.2.4.
>   gnu: Add julia-inlinestrings.
>   gnu: julia-json: Update to 0.21.3.
>   gnu: julia-weakrefstrings: Update to 1.4.0.
>   gnu: Add julia-sentinelarrays.
>   gnu: Add julia-csv.
> 
>  gnu/packages/julia-xyz.scm | 103 ++++++++++++++++++++++++++++++++++---
>  1 file changed, 97 insertions(+), 6 deletions(-)
> 
> 
> base-commit: 111bdcff48902457a7218f7ef8a80ad3dfaac3d1
> -- 
> 2.36.0
> 

It looks fine to me as it is. I'm also not sure why that particular test
is failing but I think it's fine to skip it for now.

I've pushed the patches.
Simon Tournier July 11, 2022, 11:42 a.m. UTC | #3
Hi,


On Mon, 11 Jul 2022 at 12:09, Efraim Flashner <efraim@flashner.co.il> wrote:

> I've pushed the patches.

Thanks.

Cheers,
simon

PS:
I have noticed the general status of Julia for i686-linux is really
bad; I do not have time to investigate more; maybe on spetember.