mbox series

[bug#55220,v2,0/6] Add --list-systems and --list-targets options.

Message ID 20220507161126.14553-1-othacehe@gnu.org
Headers show
Series Add --list-systems and --list-targets options. | expand

Message

Mathieu Othacehe May 7, 2022, 4:11 p.m. UTC
Hello,

In this second version, I took Ludo remarks into account.
I also added two new patches:

  platform: Add glibc-dynamic-linker field.
  ... so that the glibc-dynamic-linker procedure is using the <platform> records,

and,

  linux: Remove system->linux-architecture procedure.
  ... so that all the callers of this procedure now rely on <platform> records.

This brings us closer to having all the system specific definitions stored in
once place. Next stop is maybe to have (gnu platform) pointing to the
bootstrap executables?

Thanks,

Mathieu

Mathieu Othacehe (6):
  platform: Introduce new platforms.
  platform: Add discovery support.
  ci: Do not rely on hardcoded cross-targets lists.
  scripts: Add --list-systems and --list-targets options.
  platform: Add glibc-dynamic-linker field.
  linux: Remove system->linux-architecture procedure.

 doc/guix.texi                      |  38 ++++++----
 etc/release-manifest.scm           |   4 +-
 gnu/ci.scm                         |  15 +---
 gnu/local.mk                       |   5 ++
 gnu/packages/bioinformatics.scm    |  11 ++-
 gnu/packages/bootstrap.scm         |  47 ++++++------
 gnu/packages/cross-base.scm        |   4 +-
 gnu/packages/instrumentation.scm   |   8 +-
 gnu/packages/linux.scm             |  34 +++------
 gnu/platform.scm                   | 113 +++++++++++++++++++++++++++--
 gnu/platforms/arm.scm              |   6 +-
 gnu/platforms/hurd.scm             |   3 +-
 gnu/platforms/intel.scm            |  52 +++++++++++++
 gnu/platforms/mips.scm             |  30 ++++++++
 gnu/platforms/powerpc.scm          |  38 ++++++++++
 gnu/platforms/riscv.scm            |  30 ++++++++
 gnu/platforms/s390.scm             |  30 ++++++++
 guix/build-system/linux-module.scm |   4 +-
 guix/scripts/archive.scm           |  20 ++---
 guix/scripts/build.scm             |  84 ++++++++++++++++++---
 guix/scripts/environment.scm       |  11 +--
 guix/scripts/graph.scm             |  15 ++--
 guix/scripts/pack.scm              |  20 ++---
 guix/scripts/pull.scm              |  12 ++-
 guix/scripts/size.scm              |  13 ++--
 guix/scripts/weather.scm           |  11 ++-
 26 files changed, 489 insertions(+), 169 deletions(-)
 create mode 100644 gnu/platforms/intel.scm
 create mode 100644 gnu/platforms/mips.scm
 create mode 100644 gnu/platforms/powerpc.scm
 create mode 100644 gnu/platforms/riscv.scm
 create mode 100644 gnu/platforms/s390.scm