mbox series

[bug#55060,v4,0/8] gnu: Add python-pyvista.

Message ID 20220502211624.689372-1-paul@apatience.com
Headers show
Series gnu: Add python-pyvista. | expand

Message

Paul A. Patience May 2, 2022, 9:16 p.m. UTC
Fixed Scooby's pyvips test.
Scooby actually requires a pyvips package that is completely missing its VIPS
dependency, so I don't think there is a way around having a pyvips variant
just for Scooby.

I couldn't figure out how to build the C extension for pyvips, but that's not
relevant for Scooby; I added the package just to inherit from it in Scooby's
pyvips variant.
It could be changed in the future.
For now what's installed is the CFFI version.

I also couldn't figure out how to get some tests to pass with pyperf.
It seems like it should be easy to fix, though.

Paul A. Patience (8):
  gnu: python-meshio: Remove input labels.
  gnu: python-meshio: Remove trailing booleans.
  gnu: python-meshio: Honor #:tests? flag.
  gnu: python-meshio: Update to 5.3.4.
  gnu: Add python-pyperf.
  gnu: Add python-pyvips.
  gnu: Add python-scooby.
  gnu: Add python-pyvista.

 gnu/packages/python-science.scm |  53 +++++++++
 gnu/packages/python-xyz.scm     | 188 ++++++++++++++++++++++++++++++++
 gnu/packages/simulation.scm     |  44 ++++----
 3 files changed, 262 insertions(+), 23 deletions(-)

--
2.36.0

Comments

Ludovic Courtès May 23, 2022, 1:56 p.m. UTC | #1
Hi,

"Paul A. Patience" <paul@apatience.com> skribis:

> Fixed Scooby's pyvips test.
> Scooby actually requires a pyvips package that is completely missing its VIPS
> dependency, so I don't think there is a way around having a pyvips variant
> just for Scooby.
>
> I couldn't figure out how to build the C extension for pyvips, but that's not
> relevant for Scooby; I added the package just to inherit from it in Scooby's
> pyvips variant.
> It could be changed in the future.
> For now what's installed is the CFFI version.
>
> I also couldn't figure out how to get some tests to pass with pyperf.
> It seems like it should be easy to fix, though.

OK.  Looks like future-work items to me, not blockers.

> Paul A. Patience (8):
>   gnu: python-meshio: Remove input labels.
>   gnu: python-meshio: Remove trailing booleans.
>   gnu: python-meshio: Honor #:tests? flag.
>   gnu: python-meshio: Update to 5.3.4.
>   gnu: Add python-pyperf.
>   gnu: Add python-pyvips.
>   gnu: Add python-scooby.
>   gnu: Add python-pyvista.

Applied, thanks!

Ludo’.