mbox series

[bug#55049,0/3] gnu: Add cl-boost-{parse,re,lexer}.

Message ID 20220421014937.264841-1-paul@apatience.com
Headers show
Series gnu: Add cl-boost-{parse,re,lexer}. | expand

Message

Paul A. Patience April 21, 2022, 1:49 a.m. UTC
The PARSE and RE Common Lisp libraries (by https://github.com/massung) have
been seemingly migrated to the CL-BOOST organization
(https://github.com/cl-boost) — some of whose packages I've added in this
patch series —, probably to avoid potential conflicts with other CL library
names.
For now I've left the cl-parse and cl-re Guix packages alone, but if no one is
using them, they could be removed.

Paul A. Patience (3):
  gnu: Add cl-boost-parse.
  gnu: Add cl-boost-re.
  gnu: Add cl-boost-lexer.

 gnu/packages/lisp-xyz.scm | 90 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 90 insertions(+)

--
2.35.1

Comments

Guillaume Le Vaillant April 23, 2022, 8:23 a.m. UTC | #1
"Paul A. Patience" <paul@apatience.com> skribis:

> The PARSE and RE Common Lisp libraries (by https://github.com/massung) have
> been seemingly migrated to the CL-BOOST organization
> (https://github.com/cl-boost) — some of whose packages I've added in this
> patch series —, probably to avoid potential conflicts with other CL library
> names.
> For now I've left the cl-parse and cl-re Guix packages alone, but if no one is
> using them, they could be removed.
>
> Paul A. Patience (3):
>   gnu: Add cl-boost-parse.
>   gnu: Add cl-boost-re.
>   gnu: Add cl-boost-lexer.
>
>  gnu/packages/lisp-xyz.scm | 90 +++++++++++++++++++++++++++++++++++++++
>  1 file changed, 90 insertions(+)

I think you could replace the definitions of sbcl-parse, cl-parse and
ecl-parse by:

--8<---------------cut here---------------start------------->8---
(define-public sbcl-parse
  (deprecated-package "sbcl-parse" sbcl-boost-parse))

(define-public cl-parse
  (deprecated-package "cl-parse" cl-boost-parse))

(define-public ecl-parse
  (deprecated-package "ecl-parse" ecl-boost-parse))
--8<---------------cut here---------------end--------------->8---

and likewise for {sbcl,cl,ecl}-re. Then after some time has passed we'll
remove the deprecated packages.
Paul A. Patience April 24, 2022, 3:29 a.m. UTC | #2
On 2022-04-23 04:23:36-04:00, Guillaume Le Vaillant wrote:
> I think you could replace the definitions of sbcl-parse, cl-parse and
> ecl-parse by:
>
> (define-public sbcl-parse
>   (deprecated-package "sbcl-parse" sbcl-boost-parse))
>
> (define-public cl-parse
>   (deprecated-package "cl-parse" cl-boost-parse))
>
> (define-public ecl-parse
>   (deprecated-package "ecl-parse" ecl-boost-parse))
>
> and likewise for {sbcl,cl,ecl}-re. Then after some time has passed we'll
> remove the deprecated packages.

The problem is that cl-boost-parse's (CL) package name is BOOST-PARSE,
but cl-parse's package name is PARSE, so in fact they are not
transparently interchangeable.

Could we wrap the existing definitions of sbcl-parse, etc., with
deprecated-package?

Best regards,
Paul
Guillaume Le Vaillant April 24, 2022, 10:09 a.m. UTC | #3
"Paul A. Patience" <paul@apatience.com> skribis:

> On 2022-04-23 04:23:36-04:00, Guillaume Le Vaillant wrote:
>
> The problem is that cl-boost-parse's (CL) package name is BOOST-PARSE,
> but cl-parse's package name is PARSE, so in fact they are not
> transparently interchangeable.

Indeed, they are different packages. So let's keep the old "parse" and
"re" packages for now (and these are also the only ones that are in
Quicklisp).
Patches pushed as 3ab9bd077849912b0d3518d1ccc375a9296fd99a and
following.
Thanks.