mbox series

[bug#55044,0/8] Add python-scrapy.

Message ID 20220420172518.8609-1-felgru@posteo.net
Headers show
Series Add python-scrapy. | expand

Message

Felix Gruber April 20, 2022, 5:25 p.m. UTC
This patchset adds the Scrapy webscraping framework.

Felix Gruber (8):
  gnu: Add python-sybil.
  gnu: Add python-pydispatcher.
  gnu: Add python-queuelib.
  gnu: Add python-itemadapter.
  gnu: Add python-protego.
  gnu: Add python-parsel.
  gnu: Add python-itemloaders.
  gnu: Add python-scrapy.

 gnu/packages/python-check.scm |  30 +++++++++
 gnu/packages/python-web.scm   | 113 ++++++++++++++++++++++++++++++++++
 gnu/packages/python-xyz.scm   | 111 ++++++++++++++++++++++++++++++++-
 3 files changed, 253 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès May 2, 2022, 1:14 p.m. UTC | #1
Hi,

Felix Gruber <felgru@posteo.net> skribis:

>   gnu: Add python-sybil.
>   gnu: Add python-pydispatcher.
>   gnu: Add python-queuelib.
>   gnu: Add python-itemadapter.
>   gnu: Add python-protego.
>   gnu: Add python-parsel.
>   gnu: Add python-itemloaders.
>   gnu: Add python-scrapy.

I’ve applied the whole series with a couple of tweaks to
synopses/descriptions, as reported by ‘guix lint’.

Please take a look at
<https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>
if you haven’t already and maybe (maybe!) you’ll get shorter review
times as a result.  :-)

Thanks,
Ludo’.
Felix Gruber May 2, 2022, 4:22 p.m. UTC | #2
Hi Ludo‘,

On 5/2/22 15:14, Ludovic Courtès wrote:
> I’ve applied the whole series with a couple of tweaks to
> synopses/descriptions, as reported by ‘guix lint’.
> 
> Please take a look at
> <https://guix.gnu.org/manual/devel/en/html_node/Synopses-and-Descriptions.html>
> if you haven’t already and maybe (maybe!) you’ll get shorter review
> times as a result.  :-)

Thank you for the hint. I'll give it a read. (And I try to remember to 
run guix lint on my next patch sets.)

Kind regards,
Felix