mbox series

[bug#54934,0/4] Fix broken packages by PyYAML upgrade.

Message ID 20220414110849.2088259-1-zimon.toutoune@gmail.com
Headers show
Series Fix broken packages by PyYAML upgrade. | expand

Message

Simon Tournier April 14, 2022, 11:08 a.m. UTC
Hi,

Currently, python-pyyaml-for-awscli is not used.  Its use had been removed by
commit 21cd4c704e.  Reuse the package to fix some others; waiting their
regular updates.

Note that the package orange is still broken.  Because
python-orange-canvas-core is broken.  However, note that:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix graph --path python-orange-canvas-core python-pyyaml
python-orange-canvas-core@0.1.24
python-qasync@0.22.0
python-pyqt@5.15.2
qtbase@5.15.2
gtk+@3.24.30
rest@0.8.1
libsoup-minimal@2.72.0
samba@4.15.3
python-markdown@3.3.4
python-pyyaml@6.0
--8<---------------cut here---------------end--------------->8---

and update it to 0.1.26 is not enough, for instance.


zimoun (4):
  gnu: python-pyyaml-for-awscli: Rename and hide.
  gnu: docker-compose: Use python-pyyaml@5.
  gnu: conan: Use python-pyyaml@5.
  gnu: ganeti: Use python-pyyaml@5.

 gnu/packages/docker.scm             |  2 +-
 gnu/packages/package-management.scm |  2 +-
 gnu/packages/python-xyz.scm         | 24 +++++++++++++-----------
 gnu/packages/virtualization.scm     |  2 +-
 4 files changed, 16 insertions(+), 14 deletions(-)


base-commit: 7d990e775e76c0a898c7d4b53691d1932fc0e6eb

Comments

Ricardo Wurmus April 14, 2022, 1:19 p.m. UTC | #1
zimoun <zimon.toutoune@gmail.com> writes:

> Note that the package orange is still broken.  Because
> python-orange-canvas-core is broken.

I don’t understand.  It builds just fine here.  I tested on commit
b0dd06bd0caea46a852248ab48ab2e6aaff57752.

How is it broken?
Simon Tournier April 14, 2022, 1:28 p.m. UTC | #2
On Thu, 14 Apr 2022 at 15:20, Ricardo Wurmus <rekado@elephly.net> wrote:

> > Note that the package orange is still broken.  Because
> > python-orange-canvas-core is broken.
>
> I don’t understand.  It builds just fine here.  I tested on commit
> b0dd06bd0caea46a852248ab48ab2e6aaff57752.

I have not tested on this one since it is very recent ;-)

CommitDate: Thu Apr 14 14:53:17 2022 +0200

but it fails with 7d990e775e76c0a898c7d4b53691d1932fc0e6eb.


> How is it broken?

Like this <https://ci.guix.gnu.org/build/644998/details>


Cheers,
simon
Ricardo Wurmus April 14, 2022, 2 p.m. UTC | #3
zimoun <zimon.toutoune@gmail.com> writes:

> On Thu, 14 Apr 2022 at 15:20, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>> > Note that the package orange is still broken.  Because
>> > python-orange-canvas-core is broken.
>>
>> I don’t understand.  It builds just fine here.  I tested on commit
>> b0dd06bd0caea46a852248ab48ab2e6aaff57752.
>
> I have not tested on this one since it is very recent ;-)
>
> CommitDate: Thu Apr 14 14:53:17 2022 +0200
>
> but it fails with 7d990e775e76c0a898c7d4b53691d1932fc0e6eb.
>
>
>> How is it broken?
>
> Like this <https://ci.guix.gnu.org/build/644998/details>

I cannot reproduce this.  I also ran “guix build
/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv” on ci.guix.gnu.org to
see if I can reproduce the failure there, but it succeeded.
Simon Tournier April 14, 2022, 3:07 p.m. UTC | #4
Hi,

On Thu, 14 Apr 2022 at 16:00, Ricardo Wurmus <rekado@elephly.net> wrote:

> I cannot reproduce this.  I also ran “guix build
> /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv” on ci.guix.gnu.org to
> see if I can reproduce the failure there, but it succeeded.

Well, it is orthogonal with the submission, but for the record:

--8<---------------cut here---------------start------------->8---
$ guix build /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv\
     --no-grafts --check

[...]

test_context_menu_delete (orangecanvas.canvas.items.tests.test_graphicstextitem.TestGraphicsTextItem) ... Traceback (most recent call last):
  File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 137, in contextMenuEvent
    QGraphicsTextItem_contextMenuEvent(self, event)
  File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 144, in QGraphicsTextItem_contextMenuEvent
    menu = createStandardContextMenu(self, event.pos(), event.widget())
  File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 290, in createStandardContextMenu
    enabled=canPaste(),
  File "/tmp/guix-build-python-orange-canvas-core-0.1.24.drv-0/orange-canvas-core-0.1.24/orangecanvas/canvas/items/graphicstextitem.py", line 187, in canPaste
    return mime.hasFormat("text/plain") or mime.hasFormat("text/html")
AttributeError: 'NoneType' object has no attribute 'hasFormat'
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "python" arguments: ("-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test") exit-status: #f term-signal: 6 stop-signal: #f> 
phase `check' failed after 1.6 seconds
command "python" "-c" "import setuptools, tokenize;__file__='setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\\r\\n', '\\n');f.close();exec(compile(code, __file__, 'exec'))" "test" failed with signal 6
builder for `/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv' failed with exit code 1
build of /gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv failed
View build log at '/var/log/guix/drvs/aj/4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv.bz2'.
guix build: error: build of `/gnu/store/aj4xvw8shwjq9qpyfbswb71jk7axf26h-python-orange-canvas-core-0.1.24.drv' failed
--8<---------------cut here---------------end--------------->8---


Cheers,
simon
Ludovic Courtès April 27, 2022, 10:11 p.m. UTC | #5
Hi,

zimoun <zimon.toutoune@gmail.com> skribis:

>   gnu: python-pyyaml-for-awscli: Rename and hide.
>   gnu: docker-compose: Use python-pyyaml@5.
>   gnu: conan: Use python-pyyaml@5.
>   gnu: ganeti: Use python-pyyaml@5.

I had to adjust the first one (since python-pyyaml-for-awscli was
removed recently) and drop the last one (since ganeti was fixed in the
meantime), but at last the remaining 3 patches are now applied.

Thanks, and apologies for the delay!

Ludo’.