mbox series

[bug#54725,0/2] LLVM 14 and Chromium 99

Message ID 20220405121811.26289-1-marius@gnu.org
Headers show
Series LLVM 14 and Chromium 99 | expand

Message

Marius Bakke April 5, 2022, 12:18 p.m. UTC
Long time no see...  I have been battling poor health and injuries for
a while, but am slowly recovering.

First on my agenda is a long-overdue Chromium update.  It requires a newer
LLVM, which can not be built from individual tarballs due to
<https://github.com/llvm/llvm-project/issues/53281> and other problems
(likely fixed in 14.0.1).

This patch makes small adjustments to the LLVM and Clang build procedures
so they can be built from the LLVM "monorepo" instead of tarballs.

Feedback wanted!  I'm hoping to "fast track" these patches as Chromium 100
is already released with another slew of security fixes.  I will start
working on that next.

Marius Bakke (2):
  gnu: LLVM, Clang: Add 14.0.0.
  gnu: ungoogled-chromium: Update to 99.0.4844.84-1.

 gnu/local.mk                                  |   1 +
 gnu/packages/chromium.scm                     |  34 ++-
 gnu/packages/llvm.scm                         | 229 ++++++++++++------
 .../patches/clang-14.0-libc-search-path.patch |  94 +++++++
 gnu/packages/zig.scm                          |   2 +-
 5 files changed, 280 insertions(+), 80 deletions(-)
 create mode 100644 gnu/packages/patches/clang-14.0-libc-search-path.patch

Comments

Marius Bakke April 7, 2022, 9:19 p.m. UTC | #1
Marius Bakke <marius@gnu.org> skriver:

> Marius Bakke (2):
>   gnu: LLVM, Clang: Add 14.0.0.
>   gnu: ungoogled-chromium: Update to 99.0.4844.84-1.
>
>  gnu/local.mk                                  |   1 +
>  gnu/packages/chromium.scm                     |  34 ++-
>  gnu/packages/llvm.scm                         | 229 ++++++++++++------
>  .../patches/clang-14.0-libc-search-path.patch |  94 +++++++
>  gnu/packages/zig.scm                          |   2 +-
>  5 files changed, 280 insertions(+), 80 deletions(-)
>  create mode 100644 gnu/packages/patches/clang-14.0-libc-search-path.patch

I went ahead and pushed these patches, along with an update to
ungoogled-chromium 100.