mbox series

[bug#54701,v3,0/3] Make big cursors work in programs running on openjdk.

Message ID 20220403230525.30191-1-dannym@scratchpost.org
Headers show
Series Make big cursors work in programs running on openjdk. | expand

Message

Danny Milosavljevic April 3, 2022, 11:05 p.m. UTC
From: Danny Milosavljevic <dannym@scratchpost.org>

This patch makes xterm use libxcursor directly.
Without it, libx11 would try to dlopen("libXcursor.so.1") and fail.

Fixes <https://issues.guix.gnu.org/54654>

Danny Milosavljevic (3):
  gnu: openjdk15: Make big cursors work.
  gnu: openjdk16: Make big cursors work.
  gnu: openjdk17: Make big cursors work.

 gnu/local.mk                                  |  1 +
 gnu/packages/java.scm                         | 15 +++-
 .../openjdk-15-xcursor-no-dynamic.patch       | 72 +++++++++++++++++++
 3 files changed, 85 insertions(+), 3 deletions(-)
 create mode 100644 gnu/packages/patches/openjdk-15-xcursor-no-dynamic.patch

Comments

Danny Milosavljevic April 18, 2022, 11:01 a.m. UTC | #1
Pushed openjdk big cursors to guix master as these commits:

* Commit f4dd7bf94e1c21e0ecc1ecc1bc0afb9dce403cf5 for openjdk15
* Commit aa01b37ef66fad2cf35f4a4ca85cc8d930d12ce4 for openjdk16
* Commit 237d90a7808cfdced34b34595eba16632cbcb89e for openjdk17