mbox series

[bug#53017,00/17] Add julia-biosequences and julia-bioalignments

Message ID 20220104224502.1142878-1-zimon.toutoune@gmail.com
Headers show
Series Add julia-biosequences and julia-bioalignments | expand

Message

Simon Tournier Jan. 4, 2022, 10:45 p.m. UTC
Hi,

This series adds two useful packages for bioinformatics.

The first patch sets one inputs per line.  It is justified because a) Julia
package name can be long and often similar and b) uniformity helps.  For
instance of a)

--8<---------------cut here---------------start------------->8---
-     (list julia-arraylayouts julia-bandedmatrices julia-blockarrays
-           julia-fillarrays julia-matrixfactorizations))
+     (list julia-arraylayouts
+           julia-bandedmatrices
+           julia-blockarrays
+           julia-fillarrays
--8<---------------cut here---------------end--------------->8---

and this first patch does not trigger any rebuild.

The 3 other "adjust style" triggers some rebuild.

The second patch fixes packages without Project.toml file which are then
propagated.  Sadly, it implies the rebuild of all Julia packages for only one
problematic package: julia-indexablebitvectors.

Last, the tests of the package julia-biosymbols are still failing and I have
no clue why.  Therefore, they are turned off.  The package is correct because
used by julia-sequences and julia-alignments, both passing their test suite.

Cheers,
simon


zimoun (17):
  gnu: julia-xyz: Adjust style.
  build: julia-build-system: Create 'Project.toml' file when missing.
  gnu: julia-zygote: Adjust style.
  gnu: julia-documentertools: Adjust style.
  gnu: julia-documenter: Adjust style.
  gnu: Add julia-biogenerics.
  gnu: Add julia-indexablebitvectors.
  gnu: Add julia-twiddle.
  gnu: Add julia-simd.
  gnu: Add julia-scanbyte.
  gnu: Add julia-automa.
  gnu: Add julia-stringencodings.
  gnu: Add julia-yaml.
  gnu: Add julia-biosymbols.
  gnu: Add julia-biosequences.
  gnu: Add julia-intervaltrees.
  gnu: Add julia-bioalignments.

 doc/guix.texi                     |  19 +-
 gnu/packages/julia-xyz.scm        | 690 +++++++++++++++++++++++++-----
 guix/build/julia-build-system.scm |  33 +-
 3 files changed, 607 insertions(+), 135 deletions(-)


base-commit: b9c5dff57ff961a16c8fc24843a4535ea817e732