mbox series

[bug#48952,v2,0/6] Add godot-build-system (v2).

Message ID 20211221235548.130808-1-monego@posteo.net
Headers show
Series Add godot-build-system (v2). | expand

Message

Vinicius Monego Dec. 21, 2021, 11:55 p.m. UTC
This is my second attempt. Updated to the new standards with some small changes and other proof of concept packages.

Vinicius Monego (6):
  build-system: Add godot-build-system.
  gnu: superstarfighter: Use godot-build-system.
  gnu: Add librerama.
  gnu: Add material-maker.
  gnu: Add pixelorama.
  gnu: Add lorien.

 Makefile.am                       |   3 +
 doc/guix.texi                     |  19 +++++
 gnu/packages/game-development.scm |  47 ++++++++++++
 gnu/packages/games.scm            |  81 +++++++++-----------
 gnu/packages/graphics.scm         |  30 ++++++++
 guix/build-system/godot.scm       | 122 +++++++++++++++++++++++++++++
 guix/build/godot-build-system.scm | 123 ++++++++++++++++++++++++++++++
 7 files changed, 382 insertions(+), 43 deletions(-)
 create mode 100644 guix/build-system/godot.scm
 create mode 100644 guix/build/godot-build-system.scm


base-commit: 8f85e4f9aa0bd53d0240ea28e280551c8a066b85

Comments

Nicolas Goaziou Dec. 30, 2021, 9:43 a.m. UTC | #1
Hello,

Vinicius Monego <monego@posteo.net> writes:

> This is my second attempt. Updated to the new standards with some
> small changes and other proof of concept packages.

This looks nice. Thank you.

I just have one question: since `name' is more or less the standard
value for #:game keyword, per documentation, would it be possible to
fill it automatically?

Regards,
Vinicius Monego Dec. 30, 2021, 3:28 p.m. UTC | #2
Em qui, 2021-12-30 às 10:43 +0100, Nicolas Goaziou escreveu:
> Hello,
> 
> Vinicius Monego <monego@posteo.net> writes:
> 
> > This is my second attempt. Updated to the new standards with some
> > small changes and other proof of concept packages.
> 
> This looks nice. Thank you.
> 
> I just have one question: since `name' is more or less the standard
> value for #:game keyword, per documentation, would it be possible to
> fill it automatically?
> 
> Regards,

It is possible. The problem is that reading `name' in the build system
resolves to the package name + version, e.g. (godot-3.4) instead of
just the package name which is what I need. If there is a general way
to strip the version number or only read the package name without
passing it from the definition then it can be done.

I just noticed that the #:game keyword is duplicate in godot.scm.
Nicolas Goaziou Jan. 28, 2022, 9:49 a.m. UTC | #3
Hello,

Vinicius Monego <monego@posteo.net> writes:

> This is my second attempt. Updated to the new standards with some
> small changes and other proof of concept packages.

Now you have commit rights (congratulations!), you may want to commit
this patch set!

Regards,