mbox series

[bug#51493,0/5] Improvements to the pypi, cran, and "print" importers

Message ID 20211029212948.30148-1-ludo@gnu.org
Headers show
Series Improvements to the pypi, cran, and "print" importers | expand

Message

Ludovic Courtès Oct. 29, 2021, 9:29 p.m. UTC
Hi!

These changes were prompted by the need to be able to import
specific versions of packages so I could estimate importer/repository
accuracy:

  https://lists.gnu.org/archive/html/guix-devel/2021-10/msg00258.html

Feedback welcome!

Ludo’.

Ludovic Courtès (5):
  import: pypi: Allow imports of a specific version.
  import: cran: Allow imports of a specific version.
  import: print: Properly render packages with origins as inputs.
  import: print: Correctly handle URI lists.
  import: print: Handle patches that are origins.

 doc/guix.texi                | 16 ++++++-
 guix/import/cran.scm         | 89 +++++++++++++++++++++++-------------
 guix/import/print.scm        | 36 ++++++++++++---
 guix/import/pypi.scm         | 47 ++++++++++---------
 guix/scripts/import/cran.scm | 35 +++++++-------
 guix/scripts/import/pypi.scm | 32 +++++++------
 tests/print.scm              | 61 ++++++++++++++++++++++++
 tests/pypi.scm               | 12 +++--
 8 files changed, 232 insertions(+), 96 deletions(-)


base-commit: 7dbd5339d7e9c572afa0aa051dd304abe702cb7d

Comments

Ludovic Courtès Nov. 10, 2021, 11:26 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

>   import: pypi: Allow imports of a specific version.
>   import: cran: Allow imports of a specific version.
>   import: print: Properly render packages with origins as inputs.
>   import: print: Correctly handle URI lists.
>   import: print: Handle patches that are origins.

Pushed as b2ed40c29f578d46d42cb1c5e99bd797cea3aba0, topped with this
extra commit in the same vein:

  3756ce3267 import: print: Replace packages and origins in 'arguments'.

I’ll have to take care of the merge conflicts with ‘core-updates-frozen’
in print.scm…

Ludo’.