mbox series

[bug#51346,v2,0/4] Rework swap, add flags and dependencies.

Message ID 20211027150913.6038-1-dev@jpoiret.xyz
Headers show
Series Rework swap, add flags and dependencies. | expand

Message

Josselin Poiret Oct. 27, 2021, 3:09 p.m. UTC
Hi,

Alright, this new revised and expanded patchset should take into
account most of the previous remarks, as well as fix some corner
cases.

Akin to what is done for file system services, I've modified
swap-services so that it filters out boot-time dependencies which
cannot be managed by Shepherd.

In doing so, I noticed that the non-boot-file-system-services
procedure automagically adds mapped devices dependencies that it
detects: is that documented behaviour, are we trying to support it or
are we trying to move away from it?

The documentation should now be self-sufficient, with the example
desktop configuration updated to contain a swap file.

Josselin Poiret (4):
  gnu: system: Rework swap space support, add dependencies.
  gnu: system: Add swap flags.
  gnu: system: Filter out boot dependencies from swap-space.
  doc: Add new Swap Space section.

 doc/guix.texi                    | 136 ++++++++++++++++++++++---------
 gnu/build/file-systems.scm       |  35 +++++++-
 gnu/services/base.scm            | 109 +++++++++++++++++--------
 gnu/system.scm                   |  20 ++++-
 gnu/system/examples/desktop.tmpl |   7 +-
 gnu/system/file-systems.scm      |  24 +++++-
 guix/build/syscalls.scm          |  12 +++
 7 files changed, 267 insertions(+), 76 deletions(-)