mbox series

[bug#49946,0/3] guix: node-build-system: Support compiling addons with node-gyp.

Message ID 20210930225611.2143194-1-philip@philipmcgrath.com
Headers show
Series guix: node-build-system: Support compiling addons with node-gyp. | expand

Message

Philip McGrath Sept. 30, 2021, 10:56 p.m. UTC
Hi,

I've reworked the part of the patch series dealing with node-gyp.

I'd like to find an NPM addon package to submit as part of this series, too,
basically as a test case. If I can find one that doesn't raise too many other
complications, I may send this in as a separate patch, but feel free to try it
with tree-sitter, too.

There are a few things I'm still not sure about. I haven't made
node-build-system add libuv as an implicit input, because I think some
node-gyp addons don't actually need libuv, but maybe it's common enough that
it should be done automatically.

Likewise, I haven't tried to change the issue of `node` referring to
`node-bootstrap`, but I still think it should be changed.

These patches are also on GitLab at
<https://gitlab.com/philip1/guix-patches/-/tree/wip-node-npm-gyp>.

Improvements welcome!

-Philip


Philip McGrath (3):
  gnu: node: Avoid duplicating build phases.
  gnu: node: Update to 10.24.1 for bootstrapping.
  guix: node-build-system: Support compiling addons with node-gyp.

 gnu/packages/node.scm            | 187 ++++++++++---------------------
 guix/build-system/node.scm       |   7 +-
 guix/build/node-build-system.scm |   9 ++
 3 files changed, 74 insertions(+), 129 deletions(-)