mbox series

[bug#48702,v4,0/3] Add patatt and update b4

Message ID 20210918162853.25997-1-kyle@kyleam.com
Headers show
Series Add patatt and update b4 | expand

Message

Kyle Meyer Sept. 18, 2021, 4:28 p.m. UTC
Here's another reroll that 1) deals with conflicts that have popped up in
guix/licenses.scm and 2) accounts for patatt and b4 releases that happened
since v3 was sent.

---

This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.8.0.

 gnu/packages/version-control.scm | 37 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 38 insertions(+), 11 deletions(-)

Range-diff against v3:
1:  bda992a993 ! 1:  6c2a380249 licenses: Add Expat No Attribution license.
    @@ Commit message

      ## guix/import/utils.scm ##
     @@
    - ;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
      ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
      ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
    + ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
    @@ guix/import/utils.scm: (define (spdx-string->license str)

      ## guix/licenses.scm ##
     @@
    - ;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
      ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
      ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
    + ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
2:  8dec2fae21 ! 2:  942db96ac1 gnu: Add patatt.
    @@ gnu/packages/version-control.scm: (define-public grokmirror
     +(define-public patatt
     +  (package
     +    (name "patatt")
    -+    (version "0.4.6")
    ++    (version "0.4.8")
     +    (source
     +     (origin
     +       (method url-fetch)
     +       (uri (pypi-uri "patatt" version))
     +       (sha256
    -+        (base32 "06xrbm94a6mzrp6pih7pk4bbcbjh4xrf8y8qjg8va4qbvkhhcl2c"))))
    ++        (base32 "1jj3c2rc5lzgsk3x2bq1295g7h59y9y8vi9a0gzqh3aqka00zqak"))))
     +    (build-system python-build-system)
     +    (arguments '(#:tests? #f))          ; No tests.
     +    (propagated-inputs
3:  cb85fcb68c ! 3:  3a3d16e4c3 gnu: b4: Update to 0.7.2.
    @@ Metadata
     Author: Kyle Meyer <kyle@kyleam.com>

      ## Commit message ##
    -    gnu: b4: Update to 0.7.2.
    +    gnu: b4: Update to 0.8.0.

    -    * gnu/packages/version-control.scm (b4): Update to 0.7.2.
    +    * gnu/packages/version-control.scm (b4): Update to 0.8.0.
         [propagated-inputs]: Add patatt.
         [source]: Drop snippet for issue that is now fixed upstream.

    @@ gnu/packages/version-control.scm: (define-public patatt
        (package
          (name "b4")
     -    (version "0.6.2")
    -+    (version "0.7.2")
    ++    (version "0.8.0")
          (source
           (origin
             (method url-fetch)
    @@ gnu/packages/version-control.scm: (define-public patatt
     -           (substitute* "setup.py"
     -             (("~=") ">="))
     -           #t))))
    -+        (base32 "1zc75s6ikn5vlv2jhvw00saqyymh3dpr9b8p9w13fwll6v05s9nd"))))
    ++        (base32 "115ysciq15sxc8fd9hf7p0f4wnd5xapcfkmq8g33y1c8nbdxclbx"))))
          (build-system python-build-system)
          (arguments '(#:tests? #f))          ; No tests.
          (inputs

base-commit: 511dc6877e0664d83fd800cc601fa94c231a0d0f
--
2.33.0

Comments

Kyle Meyer Dec. 18, 2021, 7:06 a.m. UTC | #1
Here's another reroll that

 1) deals with conflicts that have popped up in guix/import/utils.scm

 2) increases the patatt version to account for release that happened since v5
    was sent

 3) updates inputs according to `guix style'

Note that updating b4 to 0.8.0 resolves the b4 build failure reported in
bug#52553 (<87ilvo7h5t.fsf@posteo.org>).

---

This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.8.0.

 gnu/packages/version-control.scm | 36 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 37 insertions(+), 11 deletions(-)

Range-diff against v4:
1:  5ce84815bc ! 1:  7b932e8ea4 licenses: Add Expat No Attribution license.
    @@ Commit message
     
      ## guix/import/utils.scm ##
     @@
    - ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
      ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
      ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
    + ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
    @@ guix/import/utils.scm: (define (spdx-string->license str)
          ("MIT"                         'license:expat)
     +    ("MIT-0"                       'license:expat-0)
          ("FTL"                         'license:freetype)
    +     ("Freetype"                    'license:freetype)
          ("GFDL-1.1"                    'license:fdl1.1+)
    -     ("GFDL-1.2"                    'license:fdl1.2+)
     
      ## guix/licenses.scm ##
     @@
2:  1cfd954f31 ! 2:  12b48f1bdb gnu: Add patatt.
    @@ Commit message
         * gnu/packages/version-control.scm (patatt): New variable.
     
      ## gnu/packages/version-control.scm ##
    -@@ gnu/packages/version-control.scm: (define-module (gnu packages version-control)
    -   #:use-module (gnu packages python)
    -   #:use-module (gnu packages python-build)
    -   #:use-module (gnu packages python-check)
    -+  #:use-module (gnu packages python-crypto)
    -   #:use-module (gnu packages python-web)
    -   #:use-module (gnu packages python-xyz)
    -   #:use-module (gnu packages readline)
     @@ gnu/packages/version-control.scm: (define-public grokmirror
      based on a manifest file published by servers.")
          (license license:gpl3+)))
    @@ gnu/packages/version-control.scm: (define-public grokmirror
     +(define-public patatt
     +  (package
     +    (name "patatt")
    -+    (version "0.4.8")
    ++    (version "0.4.9")
     +    (source
     +     (origin
     +       (method url-fetch)
     +       (uri (pypi-uri "patatt" version))
     +       (sha256
    -+        (base32 "1jj3c2rc5lzgsk3x2bq1295g7h59y9y8vi9a0gzqh3aqka00zqak"))))
    ++        (base32 "0fpbkmdlnz9s1lakw11jlrzpz4mb6f4dksdiir9g1ppq0g34sy58"))))
     +    (build-system python-build-system)
     +    (arguments '(#:tests? #f))          ; No tests.
     +    (propagated-inputs
    -+     `(("python-pynacl" ,python-pynacl)))
    ++     (list python-pynacl))
     +    (home-page "https://git.kernel.org/pub/scm/utils/patatt/patatt.git")
     +    (synopsis "Tool for cryptographic patch attestation")
     +    (description "This utility provides end-to-end cryptographic attestation
3:  520fbecd62 ! 3:  93595c3c8f gnu: b4: Update to 0.8.0.
    @@ gnu/packages/version-control.scm: (define-public patatt
          (build-system python-build-system)
          (arguments '(#:tests? #f))          ; No tests.
          (inputs
    -      `(("python-dkimpy" ,python-dkimpy)
    -        ("python-dnspython" ,python-dnspython)
    -        ("python-requests" ,python-requests)))
    +      (list python-dkimpy python-dnspython python-requests))
     +    (propagated-inputs
    -+     `(("patatt" ,patatt)))
    ++     (list patatt))
          (home-page "https://git.kernel.org/pub/scm/utils/b4/b4.git")
          (synopsis "Tool for working with patches in public-inbox archives")
          (description

base-commit: 3b2b42034c42ccb1dd8845bc03dd3a8053b54aca