mbox series

[bug#50358,core-updates-frozen,0/8] Shortened Rust bootstrap & other fixes.

Message ID 20210903152903.22385-1-maxim.cournoyer@gmail.com
Headers show
Series Shortened Rust bootstrap & other fixes. | expand

Message

Maxim Cournoyer Sept. 3, 2021, 3:29 p.m. UTC
Hello,

This series hasten the Rust bootstrap chain by about half (from about 8 to 4
hours) and fixes other things reported on the core-updates-frozen branch.
It's a world-rebuilding series (mostly due to the fix to the source repacking
code), so we might as well combine it with other world-rebuild changes that
were being put off.

Maxim Cournoyer (8):
  guix: packages: Fix repacking of plain tarballs.
  aux-files: sitecustomize: Cleanup and add explanatory comments.
  gnu: glade3: Remove sitecustomize.py workaround.
  gnu: rust: Bootstrap rust from 1.39.0 and optimize build time.
  gnu: rust: Add rust 1.54 and move all non-bootstrapping logic to it.
  gnu: Build all Rust packages using the latest rustc.
  gnu: mozjs-78: Update to 78.13.0.
  gnu: fontconfig: Add a search path for XDG_DATA_DIRS.

 gnu/local.mk                                  |   2 +-
 .../aux-files/python/sitecustomize.py         |  28 +-
 gnu/packages/crates-io.scm                    |  29 +-
 gnu/packages/fontutils.scm                    |  28 +-
 gnu/packages/gnome.scm                        |  17 +-
 gnu/packages/gnuzilla.scm                     |   8 +-
 .../patches/rust-reproducible-builds.patch    |  25 -
 gnu/packages/patches/rustc-1.39.0-src.patch   |  99 +++
 gnu/packages/rust-apps.scm                    |  12 +-
 gnu/packages/rust.scm                         | 574 ++++++++----------
 gnu/packages/shells.scm                       |   3 +-
 gnu/packages/syndication.scm                  |   1 -
 guix/packages.scm                             |   8 +-
 13 files changed, 405 insertions(+), 429 deletions(-)
 delete mode 100644 gnu/packages/patches/rust-reproducible-builds.patch
 create mode 100644 gnu/packages/patches/rustc-1.39.0-src.patch

Comments

John Kehayias Oct. 15, 2021, 5:48 a.m. UTC | #1
Hi all,

I realized I never followed up here when I had messaged https://issues.guix.gnu.org/50860  about other world rebuild changes. Namely p11-kit and Mesa.

I've worked around the p11-kit Flatpak bug in my Flatpak update patches here: https://issues.guix.gnu.org/51100  This can be done on master and I think will fix xdg-desktop-portal-gtk builds on core-updates-frozen (possibly needing a libxml2 input added for some reason).

This introduces a p11-kit-next with a version update and the Flatpak fix, so that can be the new p11-kit in the next core-updates cycle. (Assuming there are no objections to the p11-kit configuration change; I'm not sure why the flag was set the way it was originally.) The updated Flatpak package definition uses this package directly to fix its bug. But all of that doesn't need the big rebuilds, so no worries there.

As for Mesa, they continue at a fast pace. 21.1.8 is the latest bugfix release on 21.1 which should be graftable from what we have in core-updates-frozen already. I didn't submit a 21.1.8 patch but should just be a version bump.

If desired, the latest 21.2 (latest stable version) release patch is available at https://issues.guix.gnu.org/50170  I know it builds on x86_64 at least, but haven't tested dependents. Anyway, I mention here for completeness with my earlier messages.

I'm running my main machine on core-updates-frozen, so I'm happy to test how things go once we get these big rebuilds done.

John
Maxim Cournoyer Nov. 12, 2021, 5:57 a.m. UTC | #2
Hello,

Maxim Cournoyer <maxim.cournoyer@gmail.com> writes:

> Hello,
>
> This series hasten the Rust bootstrap chain by about half (from about 8 to 4
> hours) and fixes other things reported on the core-updates-frozen branch.
> It's a world-rebuilding series (mostly due to the fix to the source repacking
> code), so we might as well combine it with other world-rebuild changes that
> were being put off.
>
> Maxim Cournoyer (8):
>   guix: packages: Fix repacking of plain tarballs.
>   aux-files: sitecustomize: Cleanup and add explanatory comments.
>   gnu: glade3: Remove sitecustomize.py workaround.
>   gnu: rust: Bootstrap rust from 1.39.0 and optimize build time.
>   gnu: rust: Add rust 1.54 and move all non-bootstrapping logic to it.
>   gnu: Build all Rust packages using the latest rustc.
>   gnu: mozjs-78: Update to 78.13.0.
>   gnu: fontconfig: Add a search path for XDG_DATA_DIRS.

These commits have made it to core-updates-frozen.

Closing!

Maxim