mbox series

[bug#49969,v2,0/7] gnu: desktop: Add seatd-service-type and greetd-service-type

Message ID 20210810193626.9186-1-mail@muradm.net
Headers show
Series gnu: desktop: Add seatd-service-type and greetd-service-type | expand

Message

muradm Aug. 10, 2021, 7:36 p.m. UTC
This patch series introduces two new services;

 - seatd-service-type: simple seat management daemon
 - greetd-service-type: simple login daemon

Both services are very minimalistic in nature. Simple seatd daemon
could be said as replacement for elogind-service-type. greetd daemon
is simple replacement for mingetty/agetty.

In addition to the base services, special build of pam-mount module is
included as greetd-pam-mount. It is used to provide
auto-(mounting/unmounting) of XDG_RUNTIME_DIR. Special build is
required to avoid interference with default pam-mount, if used in
the system.

greetd provides agreety terminal greeter out of the box. Current
greetd-service-type includes configuration for greetd-agreety-session
variations, i.e. only terminal are supported at the moment.

Next step would be adding gtkgreet and/or wlgreet alternatives for
graphical greeter.

muradm (7):
  gnu: crates-io: Add rust-enquote 1.0.3
  gnu: crates-io: Add rust-pam-sys 0.5.6
  gnu: freedesktop: Add greetd 0.7.0
  gnu: admin: Add greetd-pam-mount
  gnu: desktop: Add seatd-service-type
  gnu: desktop: Add greetd-service-type
  doc: Add desktop seatd-service-type and greetd-service-type

 doc/guix.texi                | 183 ++++++++++++++++++++++++
 gnu/packages/admin.scm       |  20 +++
 gnu/packages/crates-io.scm   |  49 +++++++
 gnu/packages/freedesktop.scm |  80 +++++++++++
 gnu/services/desktop.scm     | 269 ++++++++++++++++++++++++++++++++++-
 5 files changed, 600 insertions(+), 1 deletion(-)

Comments

muradm Aug. 12, 2021, 9:55 p.m. UTC | #1
This patch series introduces two new services;

 - seatd-service-type: simple seat management daemon
 - greetd-service-type: simple login daemon

Both services are very minimalistic in nature. Simple seatd daemon
could be said as replacement for elogind-service-type. greetd daemon
is simple replacement for mingetty.

In addition to the base services, special build of pam-mount module is
included as greetd-pam-mount. It is used to provide
auto-(mounting/unmounting) of XDG_RUNTIME_DIR. Special build is
required to avoid interference with default pam-mount, if used in
the system.

greetd provides agreety terminal greeter out of the box. Current
greetd-service-type includes configuration for greetd-agreety-session
variations, i.e. only terminal are supported at the moment.

Next step would be adding gtkgreet and/or wlgreet alternatives for
graphical greeter.

muradm (10):
  gnu: crates-io: Add rust-enquote 1.0.3
  gnu: crates-io: Add rust-pam-sys 0.5.6
  gnu: freedesktop: Add greetd 0.7.0
  gnu: admin: Add greetd-pam-mount
  gnu: desktop: Add seatd-service-type
  gnu: desktop: Add greetd-service-type
  gnu: base: Add greetd to applied PAM services
  gnu: pam-mount: Add greetd to applied PAM services
  gnu: tests: Add seatd/greetd based minimal desktop system tests
  doc: Add desktop seatd-service-type and greetd-service-type

 doc/guix.texi                | 183 ++++++++++++++++++++++
 gnu/packages/admin.scm       |  33 ++++
 gnu/packages/crates-io.scm   |  49 ++++++
 gnu/packages/freedesktop.scm |  86 +++++++++++
 gnu/services/base.scm        |   3 +-
 gnu/services/desktop.scm     | 285 ++++++++++++++++++++++++++++++++++-
 gnu/services/pam-mount.scm   |   3 +-
 gnu/tests/desktop.scm        | 191 ++++++++++++++++++++++-
 8 files changed, 829 insertions(+), 4 deletions(-)
muradm Aug. 12, 2021, 10 p.m. UTC | #2
This patch series introduces two new services;

 - seatd-service-type: simple seat management daemon
 - greetd-service-type: simple login daemon

Both services are very minimalistic in nature. Simple seatd daemon
could be said as replacement for elogind-service-type. greetd daemon
is simple replacement for mingetty.

In addition to the base services, special build of pam-mount module is
included as greetd-pam-mount. It is used to provide
auto-(mounting/unmounting) of XDG_RUNTIME_DIR. Special build is
required to avoid interference with default pam-mount, if used in
the system.

greetd provides agreety terminal greeter out of the box. Current
greetd-service-type includes configuration for greetd-agreety-session
variations, i.e. only terminal are supported at the moment.

Next step would be adding gtkgreet and/or wlgreet alternatives for
graphical greeter.

muradm (10):
  gnu: crates-io: Add rust-enquote 1.0.3
  gnu: crates-io: Add rust-pam-sys 0.5.6
  gnu: freedesktop: Add greetd 0.7.0
  gnu: admin: Add greetd-pam-mount
  gnu: desktop: Add seatd-service-type
  gnu: desktop: Add greetd-service-type
  gnu: base: Add greetd to applied PAM services
  gnu: pam-mount: Add greetd to applied PAM services
  gnu: tests: Add seatd/greetd based minimal desktop system tests
  doc: Add desktop seatd-service-type and greetd-service-type

 doc/guix.texi                | 183 ++++++++++++++++++++++
 gnu/packages/admin.scm       |  33 ++++
 gnu/packages/crates-io.scm   |  49 ++++++
 gnu/packages/freedesktop.scm |  86 +++++++++++
 gnu/services/base.scm        |   3 +-
 gnu/services/desktop.scm     | 285 ++++++++++++++++++++++++++++++++++-
 gnu/services/pam-mount.scm   |   3 +-
 gnu/tests/desktop.scm        | 191 ++++++++++++++++++++++-
 8 files changed, 829 insertions(+), 4 deletions(-)
muradm Aug. 12, 2021, 10:04 p.m. UTC | #3
This patch series introduces two new services;

 - seatd-service-type: simple seat management daemon
 - greetd-service-type: simple login daemon

Both services are very minimalistic in nature. Simple seatd daemon
could be said as replacement for elogind-service-type. greetd daemon
is simple replacement for mingetty.

In addition to the base services, special build of pam-mount module is
included as greetd-pam-mount. It is used to provide
auto-(mounting/unmounting) of XDG_RUNTIME_DIR. Special build is
required to avoid interference with default pam-mount, if used in
the system.

greetd provides agreety terminal greeter out of the box. Current
greetd-service-type includes configuration for greetd-agreety-session
variations, i.e. only terminal are supported at the moment.

Next step would be adding gtkgreet and/or wlgreet alternatives for
graphical greeter.

muradm (10):
  gnu: crates-io: Add rust-enquote 1.0.3
  gnu: crates-io: Add rust-pam-sys 0.5.6
  gnu: freedesktop: Add greetd 0.7.0
  gnu: admin: Add greetd-pam-mount
  gnu: desktop: Add seatd-service-type
  gnu: desktop: Add greetd-service-type
  gnu: base: Add greetd to applied PAM services
  gnu: pam-mount: Add greetd to applied PAM services
  gnu: tests: Add seatd/greetd based minimal desktop system tests
  doc: Add desktop seatd-service-type and greetd-service-type

 doc/guix.texi                | 183 ++++++++++++++++++++++
 gnu/packages/admin.scm       |  33 ++++
 gnu/packages/crates-io.scm   |  49 ++++++
 gnu/packages/freedesktop.scm |  86 +++++++++++
 gnu/services/base.scm        |   3 +-
 gnu/services/desktop.scm     | 285 ++++++++++++++++++++++++++++++++++-
 gnu/services/pam-mount.scm   |   3 +-
 gnu/tests/desktop.scm        | 191 ++++++++++++++++++++++-
 8 files changed, 829 insertions(+), 4 deletions(-)