mbox series

[bug#48702,v3,0/3] Add patatt and update b4

Message ID 20210717130941.25146-1-kyle@kyleam.com
Headers show
Series Add patatt and update b4 | expand

Message

Kyle Meyer July 17, 2021, 1:09 p.m. UTC
Here's a reroll that 1) deals with conflicts that have popped up in
guix/licenses.scm and 2) accounts for patatt and b4 releases that have
happened since v2 was sent.

---

This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.7.2.

 gnu/packages/version-control.scm | 37 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 38 insertions(+), 11 deletions(-)

Range-diff against v2:
1:  1a4ab70088 ! 1:  bda992a993 licenses: Add Expat No Attribution license.
    @@ guix/import/utils.scm: (define (spdx-string->license str)
     
      ## guix/licenses.scm ##
     @@
    - ;;; Copyright © 2020 André Batista <nandre@riseup.net>
      ;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
      ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
    + ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
      ;;;
     @@ guix/licenses.scm: (define-module (guix licenses)
    -             edl1.0
                  epl1.0
                  epl2.0
    +             eupl1.2
     -            expat
     +            expat expat-0
                  freetype
2:  f9d1ef1ac5 ! 2:  8dec2fae21 gnu: Add patatt.
    @@ gnu/packages/version-control.scm: (define-public grokmirror
     +(define-public patatt
     +  (package
     +    (name "patatt")
    -+    (version "0.4.4")
    ++    (version "0.4.6")
     +    (source
     +     (origin
     +       (method url-fetch)
     +       (uri (pypi-uri "patatt" version))
     +       (sha256
    -+        (base32 "08v7f8rwr0gx21q2igxrw51ydlwkgcjch75xhdg0qvnknn4k1c3z"))))
    ++        (base32 "06xrbm94a6mzrp6pih7pk4bbcbjh4xrf8y8qjg8va4qbvkhhcl2c"))))
     +    (build-system python-build-system)
     +    (arguments '(#:tests? #f))          ; No tests.
     +    (propagated-inputs
3:  94b7d5062c ! 3:  cb85fcb68c gnu: b4: Update to 0.7.1.
    @@ Metadata
     Author: Kyle Meyer <kyle@kyleam.com>
     
      ## Commit message ##
    -    gnu: b4: Update to 0.7.1.
    +    gnu: b4: Update to 0.7.2.
     
    -    * gnu/packages/version-control.scm (b4): Update to 0.7.1.
    +    * gnu/packages/version-control.scm (b4): Update to 0.7.2.
         [propagated-inputs]: Add patatt.
         [source]: Drop snippet for issue that is now fixed upstream.
     
    @@ gnu/packages/version-control.scm: (define-public patatt
        (package
          (name "b4")
     -    (version "0.6.2")
    -+    (version "0.7.1")
    ++    (version "0.7.2")
          (source
           (origin
             (method url-fetch)
    @@ gnu/packages/version-control.scm: (define-public patatt
     -           (substitute* "setup.py"
     -             (("~=") ">="))
     -           #t))))
    -+        (base32 "04hwrqpvb98m6p9qj8mlblb2ynxai7zgzrlm6kbx9q2f9xl16d9z"))))
    ++        (base32 "1zc75s6ikn5vlv2jhvw00saqyymh3dpr9b8p9w13fwll6v05s9nd"))))
          (build-system python-build-system)
          (arguments '(#:tests? #f))          ; No tests.
          (inputs

base-commit: 9cb35c02164d929fcb8929e7f454df215df8cf25

Comments

Kyle Meyer Sept. 18, 2021, 4:28 p.m. UTC | #1
Here's another reroll that 1) deals with conflicts that have popped up in
guix/licenses.scm and 2) accounts for patatt and b4 releases that happened
since v3 was sent.

---

This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.8.0.

 gnu/packages/version-control.scm | 37 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 38 insertions(+), 11 deletions(-)

Range-diff against v3:
1:  bda992a993 ! 1:  6c2a380249 licenses: Add Expat No Attribution license.
    @@ Commit message

      ## guix/import/utils.scm ##
     @@
    - ;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
      ;;; Copyright © 2020 Martin Becze <mjbecze@riseup.net>
      ;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
    + ;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
    @@ guix/import/utils.scm: (define (spdx-string->license str)

      ## guix/licenses.scm ##
     @@
    - ;;; Copyright © 2020 Helio Machado <0x2b3bfa0+guix@googlemail.com>
      ;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
      ;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
    + ;;; Copyright © 2021 Noisytoot <noisytoot@disroot.org>
     +;;; Copyright © 2021 Kyle Meyer <kyle@kyleam.com>
      ;;;
      ;;; This file is part of GNU Guix.
2:  8dec2fae21 ! 2:  942db96ac1 gnu: Add patatt.
    @@ gnu/packages/version-control.scm: (define-public grokmirror
     +(define-public patatt
     +  (package
     +    (name "patatt")
    -+    (version "0.4.6")
    ++    (version "0.4.8")
     +    (source
     +     (origin
     +       (method url-fetch)
     +       (uri (pypi-uri "patatt" version))
     +       (sha256
    -+        (base32 "06xrbm94a6mzrp6pih7pk4bbcbjh4xrf8y8qjg8va4qbvkhhcl2c"))))
    ++        (base32 "1jj3c2rc5lzgsk3x2bq1295g7h59y9y8vi9a0gzqh3aqka00zqak"))))
     +    (build-system python-build-system)
     +    (arguments '(#:tests? #f))          ; No tests.
     +    (propagated-inputs
3:  cb85fcb68c ! 3:  3a3d16e4c3 gnu: b4: Update to 0.7.2.
    @@ Metadata
     Author: Kyle Meyer <kyle@kyleam.com>

      ## Commit message ##
    -    gnu: b4: Update to 0.7.2.
    +    gnu: b4: Update to 0.8.0.

    -    * gnu/packages/version-control.scm (b4): Update to 0.7.2.
    +    * gnu/packages/version-control.scm (b4): Update to 0.8.0.
         [propagated-inputs]: Add patatt.
         [source]: Drop snippet for issue that is now fixed upstream.

    @@ gnu/packages/version-control.scm: (define-public patatt
        (package
          (name "b4")
     -    (version "0.6.2")
    -+    (version "0.7.2")
    ++    (version "0.8.0")
          (source
           (origin
             (method url-fetch)
    @@ gnu/packages/version-control.scm: (define-public patatt
     -           (substitute* "setup.py"
     -             (("~=") ">="))
     -           #t))))
    -+        (base32 "1zc75s6ikn5vlv2jhvw00saqyymh3dpr9b8p9w13fwll6v05s9nd"))))
    ++        (base32 "115ysciq15sxc8fd9hf7p0f4wnd5xapcfkmq8g33y1c8nbdxclbx"))))
          (build-system python-build-system)
          (arguments '(#:tests? #f))          ; No tests.
          (inputs

base-commit: 511dc6877e0664d83fd800cc601fa94c231a0d0f
--
2.33.0