mbox series

[bug#48702,0/3] Add patatt and update b4

Message ID 20210527145046.11773-1-kyle@kyleam.com
Headers show
Series Add patatt and update b4 | expand

Message

Kyle Meyer May 27, 2021, 2:50 p.m. UTC
This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.7.0.

 gnu/packages/version-control.scm | 37 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 38 insertions(+), 11 deletions(-)


base-commit: 014421ee271f1790d81c9660d34ac26c4f2bf8b6

Comments

Xinglu Chen May 27, 2021, 9:49 p.m. UTC | #1
On Thu, May 27 2021, Kyle Meyer wrote:

> This series updates b4 to the latest version.  b4 now uses a separate tool for
> patch attestation (added in patch 2), which in turn uses a license that's not
> in guix/licenses.scm (added in patch 1).
>
>   [1/3] licenses: Add Expat No Attribution license.
>   [2/3] gnu: Add patatt.
>   [3/3] gnu: b4: Update to 0.7.0.

b4 and patatt both build for me, and I was able to check the DKIM
signature and generate a git-am-ready mbox with it.

--8<---------------cut here---------------start------------->8---
~/src/linux $ b4 am 20200313231252.64999-1-keescook@chromium.org
Looking up https://lore.kernel.org/r/20200313231252.64999-1-keescook%40chromium.org
Analyzing 5 messages in the thread
Checking attestation on all messages, may take a moment...
---
  ✓ [PATCH v2 1/2] selftests/harness: Move test child waiting logic
  ✓ [PATCH v2 2/2] selftests/harness: Handle timeouts cleanly
  ---
  ✓ Signed: DKIM/chromium.org
---
Total patches: 2
---
Cover: ./v2_20200313_keescook_selftests_harness_handle_timeouts_cleanly.cover
 Link: https://lore.kernel.org/r/20200313231252.64999-1-keescook@chromium.org
 Base: not found
       git am ./v2_20200313_keescook_selftests_harness_handle_timeouts_cleanly.mbx
--8<---------------cut here---------------end--------------->8---

Thanks for working on this!
Kyle Meyer May 27, 2021, 11:05 p.m. UTC | #2
Xinglu Chen writes:

> b4 and patatt both build for me, and I was able to check the DKIM
> signature and generate a git-am-ready mbox with it.

Great, thank you for testing things out on your end.
Kyle Meyer June 3, 2021, 6:40 a.m. UTC | #3
Since v1 of this series was sent, both patatt and b4 have had bugfix releases.
Here's a reroll with the current versions.

---

This series updates b4 to the latest version.  b4 now uses a separate tool for
patch attestation (added in patch 2), which in turn uses a license that's not
in guix/licenses.scm (added in patch 1).

  [1/3] licenses: Add Expat No Attribution license.
  [2/3] gnu: Add patatt.
  [3/3] gnu: b4: Update to 0.7.1.

 gnu/packages/version-control.scm | 37 +++++++++++++++++++++++---------
 guix/import/utils.scm            |  2 ++
 guix/licenses.scm                | 10 ++++++++-
 3 files changed, 38 insertions(+), 11 deletions(-)

Range-diff against v1:
1:  f41fc95390 = 1:  1a4ab70088 licenses: Add Expat No Attribution license.
2:  6e1a0d76fb ! 2:  f9d1ef1ac5 gnu: Add patatt.
    @@ gnu/packages/version-control.scm: (define-public grokmirror
     +(define-public patatt
     +  (package
     +    (name "patatt")
    -+    (version "0.4.3")
    ++    (version "0.4.4")
     +    (source
     +     (origin
     +       (method url-fetch)
     +       (uri (pypi-uri "patatt" version))
     +       (sha256
    -+        (base32 "0gqcrigq8alxydl6w5kxwdjfkpjhqprpwa3180sbkjlnvans71fs"))))
    ++        (base32 "08v7f8rwr0gx21q2igxrw51ydlwkgcjch75xhdg0qvnknn4k1c3z"))))
     +    (build-system python-build-system)
     +    (arguments '(#:tests? #f))          ; No tests.
     +    (propagated-inputs
3:  99fea48959 ! 3:  94b7d5062c gnu: b4: Update to 0.7.0.
    @@ Metadata
     Author: Kyle Meyer <kyle@kyleam.com>
     
      ## Commit message ##
    -    gnu: b4: Update to 0.7.0.
    +    gnu: b4: Update to 0.7.1.
     
    -    * gnu/packages/version-control.scm (b4): Update to 0.7.0.
    +    * gnu/packages/version-control.scm (b4): Update to 0.7.1.
         [propagated-inputs]: Add patatt.
         [source]: Drop snippet for issue that is now fixed upstream.
     
    @@ gnu/packages/version-control.scm: (define-public patatt
        (package
          (name "b4")
     -    (version "0.6.2")
    -+    (version "0.7.0")
    ++    (version "0.7.1")
          (source
           (origin
             (method url-fetch)
    @@ gnu/packages/version-control.scm: (define-public patatt
     -           (substitute* "setup.py"
     -             (("~=") ">="))
     -           #t))))
    -+        (base32 "089j33yyx827qpy8qkw3xk1cwis650bj5xjdn2qgckxs3sfklw7i"))))
    ++        (base32 "04hwrqpvb98m6p9qj8mlblb2ynxai7zgzrlm6kbx9q2f9xl16d9z"))))
          (build-system python-build-system)
          (arguments '(#:tests? #f))          ; No tests.
          (inputs

base-commit: 9e7d93f67566d52a2dc9006f02a4c2ad2be14442