mbox series

[bug#45875,0/3] gnu: gnunet: Update to 0.14.1-77fd866..

Message ID 20210517091142.25872-1-mail@brendan.scot
Headers show
Series gnu: gnunet: Update to 0.14.1-77fd866.. | expand

Message

Brendan Tildesley May 17, 2021, 9:11 a.m. UTC
I used some code from the above patches to update to gnunet to the latest
version 0.14.1. I ended up encountering a different set of bugs, some of the
0.14.0 bugs were fixed, and I worked with upstream to fix a couple tests, so I
ended up building from git.  I'm not sure how to correctly attribute Maxime's
work since these patches just have my name on them, but here they are anyway.

gnunet-gtk is still kinda broken. gnunet-fs-gtk segfaults, and gnunet-setup
doesn't seem to work.

Comments

M May 20, 2021, 7:16 p.m. UTC | #1
One test is failing for me (test_setu_api). I'll rebuild with --keep-failed
and send src/setu/test-suite.log. Otherwise no problems.

make  check-TESTS
make[3]: Entering directory '/tmp/guix-build-gnunet-0.14.1-00c2115.drv-0/source/src/setu'
make[4]: Entering directory '/tmp/guix-build-gnunet-0.14.1-00c2115.drv-0/source/src/setu'
FAIL: test_setu_api
PASS: perf_setu_api
============================================================================
Testsuite summary for gnunet 0.14.1
============================================================================
# TOTAL: 2
# PASS:  1
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0
============================================================================
See src/setu/test-suite.log
Please report to bug-gnunet@gnu.org
Brendan Tildesley May 21, 2021, 12:14 a.m. UTC | #2
> On 05/20/2021 9:16 PM Maxime Devos <maximedevos@telenet.be> wrote:
> 
>  
> One test is failing for me (test_setu_api). I'll rebuild with --keep-failed
> and send src/setu/test-suite.log. Otherwise no problems.

Did you try the v3? Although it should be the same. That test is supposed to be disabled. 
Maybe the substitute I added didn't actually disable it properly and the test doesn't fail 100%
of the time. I'm building it again.

+            ;; Test may be broken: https://bugs.gnunet.org/view.php?id=6114
+            (substitute* "src/setu/Makefile"
+              (("test_setu_api ") ""))
M May 21, 2021, 6:23 a.m. UTC | #3
Brendan Tildesley schreef op vr 21-05-2021 om 02:14 [+0200]:
> > On 05/20/2021 9:16 PM Maxime Devos <maximedevos@telenet.be> wrote:
> > 
> >  
> > One test is failing for me (test_setu_api). I'll rebuild with --keep-failed
> > and send src/setu/test-suite.log. Otherwise no problems.
> 
> Did you try the v3?

I couldn't find all the v4 patches (only [PATCH v4 2/3]) so I had to piece a
few together. I thought I sent a mail asking whether I got the correct patches
but apparently I didn't. It would be best if you resent the patch series.

>  Although it should be the same. That test is supposed to be disabled. 


Looking at the code, it should

            ;; Test may be broken: https://bugs.gnunet.org/view.php?id=6114
            (substitute* "src/setu/Makefile"
              (("test_setu_api ") ""))


> Maybe the substitute I added didn't actually disable it properly and the test doesn't fail 100%
> of the time. I'm building it again.

In any case, I re-ran with "--keep-failed", and this time got a different failing test:

$ cat /tmp/guix-build-gnunet-0.14.1-00c2115.drv-0/source/src/testbed/test_testbed_underlay.log 
May 20 20:42:55-459013 test_testbed_underlay-9591 WARNING Peers 0 and 2 should not get connected
May 20 20:42:55-461567 ats-9620 ERROR Assertion failed at container_multipeermap.c:347. Aborting.
May 20 20:42:55-461939 ats-9624 ERROR Assertion failed at container_multipeermap.c:347. Aborting.
May 20 20:42:55-463838 transport-api-core-9616 ERROR Error receiving from transport service (1), disconnecting temporarily.
May 20 20:42:55-466559 transport-api-core-9606 ERROR Error receiving from transport service (1), disconnecting temporarily.
May 20 20:42:55-466716 transport-api-core-9606 ERROR Error receiving from transport service (1), disconnecting temporarily.
May 20 20:42:55-466740 transport-api-core-9606 ERROR Error receiving from transport service (1), disconnecting temporarily.
FAIL test_testbed_underlay (exit status: 1)

Greetings,
Maxime.
Brendan Tildesley May 23, 2021, 8:39 a.m. UTC | #4
> On 05/21/2021 8:23 AM Maxime Devos <maximedevos@telenet.be> wrote:
...
> I couldn't find all the v4 patches (only [PATCH v4 2/3]) so I had to piece a
> few together. I thought I sent a mail asking whether I got the correct patches
> but apparently I didn't. It would be best if you resent the patch series.

Sorry I only sent the v4 for that one, I didn't realise I should have sent
the whole set.

> Looking at the code, it should
> 
>             ;; Test may be broken: https://bugs.gnunet.org/view.php?id=6114
>             (substitute* "src/setu/Makefile"
>               (("test_setu_api ") ""))
> 

The substitute was wrong but I've fixed it locally.

> 
> > Maybe the substitute I added didn't actually disable it properly and the test doesn't fail 100%
> > of the time. I'm building it again.
> 
> In any case, I re-ran with "--keep-failed", and this time got a different failing test:

Ok I don't get that one, but I also got a test_cadet_5_speed_reliable error. I'm starting to think
we should just set #:test? #f because there are too many unreliable tests. Probably the ones
I reenabled are still bad too. What do you think?