mbox series

[bug#48325,v3,0/5] DRAFT: Update julia to 1.6.1.

Message ID 20210513140818.10217-1-zimon.toutoune@gmail.com
Headers show
Series DRAFT: Update julia to 1.6.1. | expand

Message

Simon Tournier May 13, 2021, 2:08 p.m. UTC
Hi,

Here a patch set after two reviews.  Everything builds, although it is a
bit log.  It is not ready to merge and two points still need to be
addressed––aside the move of patches from ’source’ to ’arguments’.

Julia v1.6.1 requires the update of 2 core-updates packages: pcre2 and
utf8proc.  Therefore, 2 new variables are added waiting the soon
core-updates merge.  And their update in the core-updates branch will be
done in a separate patch submission.

The patch 4/5 really updating Julia is still a “draft” because the
commit message is not complete.  The real reason is twofold:

 1) an error at runtime about curl
 2) several julia packages are broken because of julia-staticarrays

About #1, it looks like:

--8<---------------cut here---------------start------------->8---
┌ Error: curl_easy_setopt: 48
└ @ Downloads.Curl /tmp/guix-build-julia-1.6.1.drv-0/julia-1.6.1/usr/share/julia/stdlib/v1.6/Downloads/src/Curl/utils.jl:36
--8<---------------cut here---------------end--------------->8---

and it is maybe related to bug#48238 [1].  Even if the example of
bug#48238 about installing the package GZip now works:

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix environment --pure --ad-hoc julia \
    -- julia -e 'using Pkg; Pkg.add("GZip"); using GZip'
WARNING: failed to select UTF-8 encoding, using ASCII
  Installing known registries into `~/.julia`
┌ Error: curl_easy_setopt: 48
└ @ Downloads.Curl /tmp/guix-build-julia-1.6.1.drv-0/julia-1.6.1/usr/share/julia/stdlib/v1.6/Downloads/src/Curl/utils.jl:36

[...]

   Added registry `General` to `~/.julia/registries/General`
   Resolving package versions...

[...]

   Installed GZip ─ v0.5.1
    Updating `~/.julia/environments/v1.6/Project.toml`
  [92fee26a] + GZip v0.5.1
    Updating `~/.julia/environments/v1.6/Manifest.toml`
  [92fee26a] + GZip v0.5.1
  [8f399da3] + Libdl
Precompiling project...
  Progress [>                                        ]  0/1
  ◐ GZip
  ◓ GZip
  ◑ GZip
  1 dependency successfully precompiled in 2 seconds
--8<---------------cut here---------------end--------------->8---


About #2, it looks like; even after updating StaticArrays.jl to the
lastest tagged version).

--8<---------------cut here---------------start------------->8---
$ ./pre-inst-env guix build julia-staticarrays

[...]

Test Summary:     | Pass  Total
SHermitianCompact |  903    903
Skipping Base.active_repl
Skipping Base.active_repl_backend
Skipping Base.active_repl
Skipping Base.active_repl_backend
Test Failed at /gnu/store/nhwk8rnix0wdbpx0w92z4yfh2n70nh9r-julia-staticarrays-1.2.0/share/julia/packages/StaticArrays/test/ambiguities.jl:19
  Expression: length(detect_ambiguities(Base, LinearAlgebra, StaticArrays)) <= allowable_ambiguities
   Evaluated: 61 <= 0
ERROR: LoadError: LoadError: There was an error during testing
in expression starting at /gnu/store/nhwk8rnix0wdbpx0w92z4yfh2n70nh9r-julia-staticarrays-1.2.0/share/julia/packages/StaticArrays/test/ambiguities.jl:13
in expression starting at /gnu/store/nhwk8rnix0wdbpx0w92z4yfh2n70nh9r-julia-staticarrays-1.2.0/share/julia/packages/StaticArrays/test/runtests.jl:38
command "julia" "--depwarn=yes" "/gnu/store/nhwk8rnix0wdbpx0w92z4yfh2n70nh9r-julia-staticarrays-1.2.0/share/julia/packages/StaticArrays/test/runtests.jl" failed with status 1
builder for `/gnu/store/98zpvhky62m64f5xfvfna4zdriggv5l8-julia-staticarrays-1.2.0.drv' failed with exit code 1
build of /gnu/store/98zpvhky62m64f5xfvfna4zdriggv5l8-julia-staticarrays-1.2.0.drv failed
View build log at '/var/log/guix/drvs/98/zpvhky62m64f5xfvfna4zdriggv5l8-julia-staticarrays-1.2.0.drv.bz2'.
guix build: error: build of `/gnu/store/98zpvhky62m64f5xfvfna4zdriggv5l8-julia-staticarrays-1.2.0.drv' failed
--8<---------------cut here---------------end--------------->8---

And I do not have an idea why it fails… Input welcome. :-)

Note that,

  ./pre-inst-env guix environment --pure --ad-hoc julia
     -- julia -e 'using Pkg; Pkg.add("StaticArrays"); using StaticArrays'

works fine.


All the best,
simon

1: <http://issues.guix.gnu.org/48238>

Jean-Baptiste Volatier (5):
  gnu: Add utf8proc-2.6.1.
  gnu: Add pcre2-10.36.
  gnu: openlibm: Update to 0.7.4.
  DRAFT gnu: julia: Update to 1.6.1.
  gnu: julia-benchmarktools: Update to 0.7.0.

 gnu/packages/julia-xyz.scm |   4 +-
 gnu/packages/julia.scm     | 292 +++++++++++++++++++++++++------------
 gnu/packages/maths.scm     |   6 +-
 gnu/packages/pcre.scm      |  14 ++
 gnu/packages/textutils.scm |  41 ++++++
 5 files changed, 257 insertions(+), 100 deletions(-)


base-commit: bddad00bffc5837e89942756fa5b7234f63f1f47
--
2.30.1

Comments

Jean-Baptiste Volatier May 23, 2021, 8:30 p.m. UTC | #1
On Thursday, May 13th, 2021 at 4:08 PM, zimoun <zimon.toutoune@gmail.com> wrote:
> 1.  an error at runtime about curl
> 2.  several julia packages are broken because of julia-staticarrays
>     About #1, it looks like:
>     --8<---------------cut here---------------start------------->8---
> ┌ Error: curl_easy_setopt: 48
> └ @ Downloads.Curl /tmp/guix-build-julia-1.6.1.drv-0/julia-1.6.1/usr/share/julia/stdlib/v1.6/Downloads/src/Curl/utils.jl:36
> --8<---------------cut here---------------end--------------->8---
>

This bug is due to Downloads.jl trying to set the following
options for libcurl:

CURLOPT_SSH_PRIVATE_KEYFILE
CURLOPT_SSH_PUBLIC_KEYFILE
CURLOPT_SSH_KNOWNHOSTS

error code 48 means that the option is unknown, this is fixed
if curl is compiled with "--with-libssh2" configure flag.
Cheers,
JB