[bug#47464,0/8] scripts: Allow option hint for various subcommands.

Message ID 20210329101638.53217-1-zimon.toutoune@gmail.com
Headers show
Series scripts: Allow option hint for various subcommands. | expand

Message

Simon Tournier March 29, 2021, 10:16 a.m. UTC
Hi,

The patch set replaces all the 'args-fold*' by 'parse-command-line'.  Doing
so, all the option typos are hinted.

It could be only one commit (squashing) but it appeared me easier in case
something is wrong; I expect nothing! :-)

I have checked trying various combinations.  Note that
"tests/guix-describe.sh" is SKIP because the test does not work when using
worktree.

Well, a double-check is really welcome. :-)


All the remaining subcommands---authenticate, container, git, import, offload
and substitute---needs a rewriting of how they parse the command line
arguments.

Cheers,
simon



zimoun (8):
  scripts: describe: Replace 'args-fold*' by 'parse-command-line'.
  scripts: discover: Replace 'args-fold*' by 'parse-command-line'.
  scripts: download: Replace 'args-fold*' by 'parse-command-line'.
  scripts: edit: Replace 'args-fold*' by 'parse-command-line'.
  scripts: publish: Replace 'args-fold*' by 'parse-command-line'.
  scripts: repl: Replace 'args-fold*' by 'parse-command-line'.
  scripts: search: Replace 'args-fold*' by 'parse-command-line'.
  scripts: show: Replace 'args-fold*' by 'parse-command-line'.

 guix/scripts/describe.scm | 10 ++++------
 guix/scripts/discover.scm | 12 ++++++------
 guix/scripts/download.scm | 17 ++++++++---------
 guix/scripts/edit.scm     | 10 ++++------
 guix/scripts/publish.scm  | 12 ++++++------
 guix/scripts/repl.scm     | 11 +++++------
 guix/scripts/search.scm   |  9 ++++-----
 guix/scripts/show.scm     | 10 ++++------
 8 files changed, 41 insertions(+), 50 deletions(-)


base-commit: 6e7ba45357078b31a369b23f8a9f38302dfcbb10

Comments

Ludovic Courtès April 1, 2021, 12:57 p.m. UTC | #1
Hi!

zimoun <zimon.toutoune@gmail.com> skribis:

> The patch set replaces all the 'args-fold*' by 'parse-command-line'.  Doing
> so, all the option typos are hinted.

Yay!

> It could be only one commit (squashing) but it appeared me easier in case
> something is wrong; I expect nothing! :-)
>
> I have checked trying various combinations.  Note that
> "tests/guix-describe.sh" is SKIP because the test does not work when using
> worktree.
>
> Well, a double-check is really welcome. :-)

All the tests pass, LGTM!

> All the remaining subcommands---authenticate, container, git, import, offload
> and substitute---needs a rewriting of how they parse the command line
> arguments.

Future work.

Applied, thanks!

Ludo’.