mbox series

[bug#41189,v2,0/4] Add Fakechroot engine for 'guix pack -RR'

Message ID 20200513125215.27740-1-ludo@gnu.org
Headers show
Series Add Fakechroot engine for 'guix pack -RR' | expand

Message

Ludovic Courtès May 13, 2020, 12:52 p.m. UTC
Hello!

This version incorporates changes discussed in this thread along with
subsequent cleanups:

  • Set ‘GCONV_PATH’.

  • Build an ld.so audit module to rewrite store file names read
    from RUNPATH entries and the likes.

  • Get rid of the ‘--library-path’ argument to ld.so, which is now
    useless since the audit module takes care of rewriting .so file
    names.  This simplifies both ‘exec_with_loader’ in the wrapper
    and ‘wrapped-package’ in ‘guix pack’.

Ludo’.

Ludovic Courtès (4):
  pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable.
  pack: Factorize store references in wrapper.
  gnu: Add fakechroot.
  pack: Add relocation via ld.so and fakechroot.

 Makefile.am                               |   1 +
 doc/guix.texi                             |  43 +++-
 gnu/packages/aux-files/pack-audit.c       |  85 ++++++++
 gnu/packages/aux-files/run-in-namespace.c | 251 +++++++++++++++++++---
 gnu/packages/linux.scm                    |  30 +++
 guix/scripts/pack.scm                     |  87 +++++++-
 tests/guix-pack-relocatable.sh            |  23 ++
 7 files changed, 479 insertions(+), 41 deletions(-)
 create mode 100644 gnu/packages/aux-files/pack-audit.c

Comments

Ludovic Courtès May 14, 2020, 3:24 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

>   pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable.
>   pack: Factorize store references in wrapper.
>   gnu: Add fakechroot.
>   pack: Add relocation via ld.so and fakechroot.

Pushed as 6456232164890dbf5aa20394ee24637feb4b7b9e!

Ludo’.