mbox series

[bug#40149,0/5] Assorted 'guix deploy' improvements

Message ID 20200320140433.27868-1-ludo@gnu.org
Headers show
Series Assorted 'guix deploy' improvements | expand

Message

Ludovic Courtès March 20, 2020, 2:04 p.m. UTC
Hello!

The first patch arranges so that a single round trip is enough
to perform all the sanity checks on the remote machine.  Previously,
we’d build N derivations, send their results, and perform N remote
evaluation (with N typically in the 3–5 range depending on details
of the OS config.)

(There’s a more general optimization pattern lurking here: I’d really
like to find a way to somehow gather operations like ‘remote-eval’ that
are more efficiently done as a batch, and then scatter results back
to their continuations.  I’ve been thinking about this for some time
and it still hasn’t clicked.  Ideas welcome!)

The remaining patches are basic UI improvements.

Feedback welcome!

Ludo’.

Ludovic Courtès (5):
  machine: ssh: Make sanity checks in a single round trip.
  ui: Add 'indented-string'.
  deploy: Show what machines will be deployed.
  deploy: Write a message upon successful deployment.
  machine: ssh: Better report missing initrd modules.

 gnu/machine/ssh.scm     | 138 +++++++++++++++++++++++-----------------
 guix/scripts/deploy.scm |  23 ++++++-
 guix/scripts/pull.scm   |  17 +----
 guix/ui.scm             |  18 ++++++
 4 files changed, 123 insertions(+), 73 deletions(-)

Comments

Ludovic Courtès March 23, 2020, 9:49 a.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

>   machine: ssh: Make sanity checks in a single round trip.
>   ui: Add 'indented-string'.
>   deploy: Show what machines will be deployed.
>   deploy: Write a message upon successful deployment.
>   machine: ssh: Better report missing initrd modules.

Pushed as 8bc745052e051d142213a0ea74c39bdd7c5ace70.

Ludo’.