mbox series

[bug#36578,0/9] Modernize the API of the 'derivation' primitive

Message ID 20190710170408.21321-1-ludo@gnu.org
Headers show
Series Modernize the API of the 'derivation' primitive | expand

Message

Ludovic Courtès July 10, 2019, 5:04 p.m. UTC
Hello Guix!

This is the continuation of the season cleanup!  These patches
adjust <lowered-gexp> to refer to <derivation-input>.

More importantly, they change the calling convention of the
‘derivation’ primitive such that #:inputs must be a list
of <derivation-input>, and a new #:sources parameter must be
used to pass “sources” (content-addressed files added to the
store with the ‘add-to-store’ RPC or similar.)  This replaces
the former weird tuples used as #:inputs.  The weird tuples
are still allowed but deprecated.

There are few users of ‘derivation’ and ‘raw-derivation’.  One
of them is ‘build-expression->derivation’, which I hope to
officially deprecate soonish in favor of ‘gexp->derivation’; in
the meantime, it still uses the deprecated calling convention
but deprecation warnings are disabled in this case.

Eventually, we’ll be able to build <derivation> entirely in
memory, which would allow us to create .drv files in the store
at once (maybe with RPC pipelining), or to not create them
at all.  We’ll see…

Feedback welcome!

Ludo’.

Ludovic Courtès (9):
  derivations: 'derivation' primitive accepts <derivation> and
    #:sources.
  gexp: <lowered-gexp> separates sources from derivation inputs.
  gnu: guile-bootstrap: Use the new 'derivation' calling convention.
  download: Use the new 'derivation' calling convention.
  derivations: 'map-derivation' uses the new 'derivation' calling
    convention.
  derivations: Update tests to use new calling convention.
  derivations: Deprecate the previous calling convention.
  gexp: 'lowered-gexp-guile' now returns a <derivation-input>.
  channels: Avoid use of 'derivation-input-path'.

 gnu/packages/bootstrap.scm |  7 +--
 guix/channels.scm          |  5 ++-
 guix/derivations.scm       | 65 ++++++++++++++++++++-------
 guix/download.scm          |  3 +-
 guix/gexp.scm              | 92 ++++++++++++++++++++------------------
 guix/remote.scm            | 38 +++++-----------
 po/guix/POTFILES.in        |  1 +
 tests/derivations.scm      | 89 +++++++++++++++---------------------
 tests/gexp.scm             |  8 ++--
 9 files changed, 159 insertions(+), 149 deletions(-)

Comments

Ludovic Courtès July 15, 2019, 8:46 a.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> skribis:

>   derivations: 'derivation' primitive accepts <derivation> and
>     #:sources.
>   gexp: <lowered-gexp> separates sources from derivation inputs.
>   gnu: guile-bootstrap: Use the new 'derivation' calling convention.
>   download: Use the new 'derivation' calling convention.
>   derivations: 'map-derivation' uses the new 'derivation' calling
>     convention.
>   derivations: Update tests to use new calling convention.
>   derivations: Deprecate the previous calling convention.
>   gexp: 'lowered-gexp-guile' now returns a <derivation-input>.
>   channels: Avoid use of 'derivation-input-path'.

Pushed!

Ludo’.