mbox series

[bug#35333,0/6] Add Yubikey Manager and Its Dependencies

Message ID 20190420003814.5120-1-cmmarusich@gmail.com
Headers show
Series Add Yubikey Manager and Its Dependencies | expand

Message

Christopher Marusich April 20, 2019, 12:38 a.m. UTC
Hi,

This patch series adds Yubikey Manager (ykman) and its dependencies.
It applies cleanly to fd6d2fd871aa3eb443037483998b7790d15be709.

I've validated that the ykman CLI works with my own personal YubiKey 4
Nano that I've owned for a few years.  I've verified that rudimentary
operations such as "ykman openpgp info" and "ykman mode OTP+FIDO+CCID"
succeed, but I didn't exhaustively check all possible operations.

Along the way, I've noticed that Mozilla's Public Suffix List database
is embedded in at least one existing Guix package: ruby-public-suffix.
I've opened a bug report about this:

  https://debbugs.gnu.org/cgi/bugreport.cgi?bug=35332

We can fix that bug by replacing the bundled copy with the one
provided by the public-suffix-list package introduced here.

Chris Marusich (6):
  gnu: Add python-pyfakefs and python2-pyfakefs.
  gnu: Add python-pyscard and python2-pyscard.
  gnu: Add libu2f-host.
  gnu: Add public-suffix-list.
  gnu: Add python-fido2 and python2-fido2.
  gnu: Add python-yubikey-manager and python2-yubikey-manager.

 gnu/local.mk                                  |   1 +
 gnu/packages/check.scm                        |  49 ++++
 gnu/packages/dns.scm                          |  51 +++++
 .../python-pyfakefs-remove-bad-test.patch     |  23 ++
 gnu/packages/security-token.scm               | 211 +++++++++++++++++-
 5 files changed, 334 insertions(+), 1 deletion(-)
 create mode 100644 gnu/packages/patches/python-pyfakefs-remove-bad-test.patch

Comments

Christopher Marusich April 20, 2019, 1:07 a.m. UTC | #1
Hi,

The patches follow this email.  I've tried to invoke git-send-email so
that all 6 patches appear as replies to this email, like this:

  git send-email --to=35333@debbugs.gnu.org --compose 000[1-6]*

I then manually filled in the body and the following headers:

  From: Chris Marusich <cmmarusich@gmail.com>
  Subject: Re: [bug#35333] [PATCH 0/6] Add Yubikey Manager and Its Dependencies
  In-Reply-To: <20190420003814.5120-1-cmmarusich@gmail.com>

This is tedious, but hopefully it'll work!

Chris
Ricardo Wurmus April 20, 2019, 7:32 a.m. UTC | #2
Hi Chris,

> I then manually filled in the body and the following headers:
>
>   From: Chris Marusich <cmmarusich@gmail.com>
>   Subject: Re: [bug#35333] [PATCH 0/6] Add Yubikey Manager and Its Dependencies

I don’t think this is necessary.

>   In-Reply-To: <20190420003814.5120-1-cmmarusich@gmail.com>

You can use “--in-reply-to” from the command line instead.
Danny Milosavljevic April 24, 2019, 7:24 p.m. UTC | #3
Hi Chris,

the series LGTM!
Christopher Marusich April 25, 2019, 4:14 a.m. UTC | #4
Hi Ricardo and Danny,

Thank you for your time!

Ricardo Wurmus <rekado@elephly.net> writes:

>> I then manually filled in the body and the following headers:
>>
>>   From: Chris Marusich <cmmarusich@gmail.com>
>>   Subject: Re: [bug#35333] [PATCH 0/6] Add Yubikey Manager and Its Dependencies
>
> I don’t think this is necessary.
>
>>   In-Reply-To: <20190420003814.5120-1-cmmarusich@gmail.com>
>
> You can use “--in-reply-to” from the command line instead.

Thank you for the tip!

Danny Milosavljevic <dannym@scratchpost.org> writes:

> the series LGTM!

I've committed this as 4728806185a0d85155ea4db795d1643a8c849d65.

Closing!