mbox series

[0/7] Add patchwork package and service.

Message ID 20181104150321.22093-1-mail@cbaines.net
Headers show
Series Add patchwork package and service. | expand

Message

Christopher Baines Nov. 4, 2018, 3:03 p.m. UTC
These patches add a package for patchwork, a web-based patch tracking
system, along with some missing dependencies and the beginnings of a
system service and test.

Everything up to the patchwork package should be ready to merge, but the
patchwork package, service and system test is currently very rough and
unready.

This 2nd revision of the patches improves the service a bit.


Christopher Baines (7):
  gnu: Add python-jsmin.
  gnu: Add python-slimit.
  gnu: Add python-django-pipeline.
  gnu: Add python-django-jinja.
  gnu: Add python-django-debug-toolbar.
  gnu: Add patchwork.
  services: Add patchwork.

 gnu/packages/django.scm     | 130 ++++++++++++++++
 gnu/packages/patchutils.scm | 103 +++++++++++++
 gnu/packages/python-web.scm |  50 ++++++
 gnu/services/web.scm        | 297 +++++++++++++++++++++++++++++++++++-
 gnu/tests/web.scm           | 104 ++++++++++++-
 5 files changed, 682 insertions(+), 2 deletions(-)