mbox series

[bug#53144,0/13] Make more git-using packages auto-updatable

Message ID 0498a1400cfa72db28da35e46d64bf6e1267b3d7.camel@telenet.be
Headers show
Series Make more git-using packages auto-updatable | expand

Message

M Jan. 9, 2022, 7:08 p.m. UTC
X-Debbugs-CC: liliana.prikler@gmail.com ludo@gnu.org iskarian@mgsn.dev public@yoctocell.xyz

Hi,

This patch series makes more packages that use 'git-fetch'
auto-updatable.  The first 9 patches are specifically for Minetest packages.
The following three patches make packages written in the folowing style
auto-updatable:

(define-public foo
  ;; Upstream never makes any releases, so use the latest commit
  ;; from the 'stable' branch instead.
  (let ((commit "deadbeef...")
        (revision "9"))
    (package
      (name "foo")
      (version (git-version "0" revision commit))
      (source [git-fetch etc.])
      [etc.]
      (properties '((with-latest-git-commit . "refs/heads/stable"))))))

To do so, make sure with-latest-git-commit is set, and run
"./pre-inst-env guix refresh -t -u foo".  It will update
the commit and revision.

The last patch sets the property 'with-latest-git-commit'.

tests/channels.scm ("channel-news, one entry") fails, TBI.
"make check" is running, I'll send a message about what fails
and succeeds.

You can also grab a copy from https://notabug.org/maximed/guix-gnunet
(branch: wip-git-fetch2, 358c8f64966c423927f22f1c0ee29e85e70b1af8)

Greetings,
Maxime

Comments

M Jan. 9, 2022, 7:49 p.m. UTC | #1
The failing tests are:

 * tests/channels.scm: "channel-news, one entry"
 * tests/pack.scm, due to networking issues
M June 6, 2022, 3:15 p.m. UTC | #2
The remote-create-detached issue is fixed by
<https://gitlab.com/guile-git/guile-git/-/merge_requests/35>.