[bug#33134,5/5] guix-install.sh: Update sys_authorize_build_farms.

Message ID 20181103011138.66825-1-s@ricketyspace.net
State Accepted
Headers show
Series Add auto yes/no switch to guix-install.sh | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

rsiddharth Nov. 3, 2018, 1:11 a.m. UTC
* etc/guix-install.sh (sys_authorize_build_farms): Don't prompt
if AUTO_YN is set.
---
 etc/guix-install.sh | 7 +++++--
 1 file changed, 5 insertions(+), 2 deletions(-)

Comments

Danny Milosavljevic Nov. 6, 2018, 11:31 a.m. UTC | #1
Hi,

On Fri,  2 Nov 2018 21:11:38 -0400
rsiddharth <s@ricketyspace.net> wrote:

> -            *) _msg "Please answer yes or no.";
> +            *) _msg "Please answer yes or no."; yn=""

Does this make it conditionally interactive?  Would it be better to "exit 1" here?

Patch

diff --git a/etc/guix-install.sh b/etc/guix-install.sh
index 9bf52db41..18adc17a2 100755
--- a/etc/guix-install.sh
+++ b/etc/guix-install.sh
@@ -355,8 +355,11 @@  sys_enable_guix_daemon()
 
 sys_authorize_build_farms()
 { # authorize the public keys of the two build farms
+    local yn=$AUTO_YN
+
     while true; do
-        read -p "Permit downloading pre-built package binaries from the project's build farms? (yes/no) " yn
+        [[ -n $yn ]] || read -p "Permit downloading pre-built package binaries from the project's build farms? (yes/no) " yn
+
         case $yn in
             [Yy]*) guix archive --authorize < "${ROOT_HOME}/.guix-profile/share/guix/hydra.gnu.org.pub" &&
                          _msg "${PAS}Authorized public key for hydra.gnu.org";
@@ -365,7 +368,7 @@  sys_authorize_build_farms()
                    break;;
             [Nn]*) _msg "${INF}Skipped authorizing build farm public keys"
                    break;;
-            *) _msg "Please answer yes or no.";
+            *) _msg "Please answer yes or no."; yn=""
         esac
     done
 }