[bug#60293] gnu: Add sbcl-stumpwm-battery-portable
Commit Message
---
gnu/packages/wm.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)
Comments
Patch pushed as 8aa104752cb6a61f2ac689c31ac627ccab32f7fe with a few
modifications.
Thanks.
@@ -2358,6 +2358,24 @@ (define-public sbcl-stumpwm-notify
by default.")
(license license:gpl3+)))
+(define-public sbcl-stumpwm-battery-portable
+ (package
+ (inherit stumpwm-contrib)
+ (name "sbcl-stumpwm-battery-portable")
+ (build-system asdf-build-system/sbcl)
+ (inputs (list
+ cl-ppcre
+ (list stumpwm "lib")))
+ (arguments
+ '(#:asd-systems '("battery-portable")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "modeline/battery-portable"))))))
+ (synopsis "A battery level indicator for the mode-line")
+ (description "This module provides a battery-level indicator for the
+modeline. It can be displayed in the mode-line with %B.")))
+
(define-public lemonbar
(package
(name "lemonbar")