Message ID | 87lg3z8nc2.fsf@gmail.com |
---|---|
State | Accepted |
Headers | show |
Series | [bug#33986,1/9] gnu: Add ocaml-sexplib0. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
cbaines/applying patch | fail | Apply failed |
Le 3 janvier 2019 10:18:32 GMT+03:00, Gabriel Hondet <gabrielhondet@gmail.com> a écrit : > >* gnu/packages/ocaml.scm (ocaml-sexplib0): New variable. >--- > gnu/packages/ocaml.scm | 25 +++++++++++++++++++++++++ > 1 file changed, 25 insertions(+) > >diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm >index e4f17133d..bece14477 100644 >--- a/gnu/packages/ocaml.scm >+++ b/gnu/packages/ocaml.scm >@@ -5105,3 +5105,28 @@ speedup, polymorphic variants and optional >syntax for tuples and variants. >yojson package. The program @code{atdgen} can be used to derive >OCaml-JSON > serializers and deserializers from type definitions.") > (license license:bsd-3))) >+ >+(define-public ocaml-sexplib0 >+ (package >+ (name "ocaml-sexplib0") >+ (version "0.11.0") >+ (home-page "https://github.com/janestreet/sexplib0") >+ (source >+ (origin >+ (method git-fetch) >+ (uri (git-reference >+ (url (string-append home-page ".git")) >+ (commit (string-append "v" version)))) >+ (file-name (git-file-name name version)) >+ (sha256 >+ (base32 >+ "07v3ggyss7xhfv14bjk1n87sr42iqwj4cgjiv2lcdfkqk49i2bmi")))) >+ (build-system dune-build-system) >+ (arguments >+ '(#:tests? #f)) >+ (synopsis "Library containing the definition of S-expressions and >some >+base converters") >+ (description "Part of Jane Street's Core library The Core suite of >+libraries is an industrial strength alternative to OCaml's standard >library >+that was developed by Jane Street, the largest industrial user of >OCaml.") >+(license license:expat))) Hi Gabriel, thank you for these patches! I'll need a bit more time to review them because I'm travelling. We already have them, but I think they are only for ocaml-4.02. In the meantime, could you add a comment to explain why you disabled tests whenever you did? It could be as short as "; no tests". Also, do you know what happened with the versionning?
Finally pushed as a41bca08e27da0d4db176c8fadf21e278af4a2b6 - 4d390cad2510797a68f473db347699e748c92e42. Sorry for taking so long! I've removed ocaml-parsetree-migrate because it was already present in guix. I've also slightly modified the descriptions (adding a dot or making the first sentence a full sentence in some packages). Otherwise, they were very good, thank you!
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm index e4f17133d..bece14477 100644 --- a/gnu/packages/ocaml.scm +++ b/gnu/packages/ocaml.scm @@ -5105,3 +5105,28 @@ speedup, polymorphic variants and optional syntax for tuples and variants. yojson package. The program @code{atdgen} can be used to derive OCaml-JSON serializers and deserializers from type definitions.") (license license:bsd-3))) + +(define-public ocaml-sexplib0 + (package + (name "ocaml-sexplib0") + (version "0.11.0") + (home-page "https://github.com/janestreet/sexplib0") + (source + (origin + (method git-fetch) + (uri (git-reference + (url (string-append home-page ".git")) + (commit (string-append "v" version)))) + (file-name (git-file-name name version)) + (sha256 + (base32 + "07v3ggyss7xhfv14bjk1n87sr42iqwj4cgjiv2lcdfkqk49i2bmi")))) + (build-system dune-build-system) + (arguments + '(#:tests? #f)) + (synopsis "Library containing the definition of S-expressions and some +base converters") + (description "Part of Jane Street's Core library The Core suite of +libraries is an industrial strength alternative to OCaml's standard library +that was developed by Jane Street, the largest industrial user of OCaml.") +(license license:expat)))