[bug#33866,1/2] gnu: Add emacs-dedukti-mode.

Message ID 87wonxwimk.fsf@gmail.com
State Accepted
Headers show
Series [bug#33866,1/2] gnu: Add emacs-dedukti-mode. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Gabriel Hondet Dec. 25, 2018, 6:45 p.m. UTC
* gnu/packages/emacs.scm (emacs-dedukti-mode): New variable.
---
 gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Julien Lepiller Dec. 26, 2018, 2:27 p.m. UTC | #1
Le Tue, 25 Dec 2018 19:45:07 +0100,
Gabriel Hondet <gabrielhondet@gmail.com> a écrit :

> * gnu/packages/emacs.scm (emacs-dedukti-mode): New variable.
> ---
>  gnu/packages/emacs.scm | 22 ++++++++++++++++++++++
>  1 file changed, 22 insertions(+)
> 
> diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
> index 7fdcfb1a3..02fd25fef 100644
> --- a/gnu/packages/emacs.scm
> +++ b/gnu/packages/emacs.scm
> @@ -41,6 +41,7 @@
>  ;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
>  ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
>  ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
> +;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -12854,3 +12855,24 @@ functions to ensure they are called with the
> right arguments during testing.") @code{wordnet}.  Features include
> completion, if the query is not found too ambiguous and navigation in
> the result buffer.") (license license:gpl3+))))
> +
> +(define-public emacs-dedukti-mode
> +  (let ((commit "d7c3505a1046187de3c3aeb144455078d514594e"))
> +    (package
> +      (name "emacs-dedukti-mode")
> +      (version (git-version "0" "0" commit))
> +      (home-page "https://github.com/rafoo/dedukti-mode")
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url home-page)
> +                      (commit commit)))
> +                (sha256
> +                 (base32
> +
> "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
> +                (file-name (git-file-name name version))))
> +      (build-system emacs-build-system)
> +      (synopsis "Emacs major mode for Dedukti files")
> +      (description "This package provides an Emacs major mode for
> editing +Dedukti files.")
> +      (license license:cecill-b))))

I'm not an emacs user, so I'm a bit worried that this package won't be
able to find dedukti (it's not an input at all!). I see this in the
code:

(defcustom dedukti-path "/usr/bin/dkcheck" ...)

I would say that it means that dedukti-mode will not find dkcheck at
all... What do you think? If that's the case, could you add dedukti as
an input and substitute* that path in a custom phase? Or make sure it
loads dedukti from the path at least.

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 7fdcfb1a3..02fd25fef 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -41,6 +41,7 @@ 
 ;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
 ;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018 Gabriel Hondet <gabrielhondet@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -12854,3 +12855,24 @@  functions to ensure they are called with the right arguments during testing.")
 @code{wordnet}.  Features include completion, if the query is not found
 too ambiguous and navigation in the result buffer.")
       (license license:gpl3+))))
+
+(define-public emacs-dedukti-mode
+  (let ((commit "d7c3505a1046187de3c3aeb144455078d514594e"))
+    (package
+      (name "emacs-dedukti-mode")
+      (version (git-version "0" "0" commit))
+      (home-page "https://github.com/rafoo/dedukti-mode")
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url home-page)
+                      (commit commit)))
+                (sha256
+                 (base32
+                  "1842wikq24c8rg0ac84vb1qby9ng1nssxswyyni4kq85lng5lcrp"))
+                (file-name (git-file-name name version))))
+      (build-system emacs-build-system)
+      (synopsis "Emacs major mode for Dedukti files")
+      (description "This package provides an Emacs major mode for editing
+Dedukti files.")
+      (license license:cecill-b))))