Commit Message
Hello!
The following patch adds Japanese input method related library.
Regards,
--
Milran
Comments
Hi,
milranmike <milranmike@protonmail.com> skribis:
> From 0c7f80c52468ddb078ff895c5e73be51d8ced23a Mon Sep 17 00:00:00 2001
> From: mirlan <milranmike@protonmail.com>
> Date: Wed, 5 Oct 2022 17:56:19 +0900
> Subject: [PATCH] Add libskk
>
> ---
> gnu/packages/language.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
Applied, thanks!
Ludo’.
From 0c7f80c52468ddb078ff895c5e73be51d8ced23a Mon Sep 17 00:00:00 2001
From: mirlan <milranmike@protonmail.com>
Date: Wed, 5 Oct 2022 17:56:19 +0900
Subject: [PATCH] Add libskk
---
gnu/packages/language.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)
@@ -5,6 +5,7 @@
;;; Copyright © 2019 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2020 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2022 Milran <milranmike@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -923,3 +924,31 @@ (define-public praat
analysis (pitch, formant, intensity, ...), speech synthesis, labelling, segmenting
and manipulation.")
(license license:gpl2+)))
+
+(define-public libssk
+ (package
+ (name "libskk")
+ (version "1.0.5")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ueno/libskk")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0y279pcgs3jrsi9vzx086xhz9jbz23dqqijp4agygc9ackp9sxy5"))))
+ (build-system gnu-build-system)
+ (native-inputs (list autoconf
+ automake
+ gettext-minimal
+ gobject-introspection
+ libtool
+ pkg-config
+ vala))
+ (inputs (list libgee json-glib libxkbcommon))
+ (home-page "https://github.com/ueno/libskk")
+ (synopsis "Dealing Japanese kana-to-kanji conversion")
+ (description
+ "libskk is a library to deal with Japanese kana-to-kanji conversion method.")
+ (license license:gpl3+)))
--
2.37.3