@@ -24,6 +24,7 @@
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2018 Nam Nguyen <namn@berkeley.edu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1555,3 +1556,46 @@ to automatically turn it on on login.")
(description "This package provides a small utility for inverting the
colors on all monitors attached to an XRandR-capable X11 display server.")
(license license:gpl3+)))
+
+(define-public sct
+ (package
+ (name "sct")
+ (version "0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://www.umaxx.net/dl/sct-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0r57z9ki8pvxhawfxys0v5h85z2x211sqxki0xvk1bga88ryldlv"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'replace-cc-with-gcc
+ ;; Use gcc in Makefile.
+ (lambda _
+ (substitute* "Makefile"
+ (("CC\\?\\=gcc")
+ "CC=gcc"))))
+ (delete 'configure)
+ (delete 'check)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (install-file "sct" (string-append out "/bin"))
+ (install-file "sctd.sh" (string-append out "/bin"))
+ (mkdir (string-append out "/man"))
+ (mkdir (string-append out "/man/man1"))
+ (install-file "sct.1" (string-append out "/man/man1"))
+ (install-file "sctd.1" (string-append out "/man/man1"))
+ #t))))))
+ (inputs
+ `(("libxrandr" ,libxrandr)))
+ (home-page "https://www.umaxx.net/")
+ (synopsis "Set the color temperature of the screen")
+ (description "@code{sct} is a lightweight utility to set the color
+temperature of the screen.")
+ (license license:bsd-3)))