[bug#55141] gnu: Add emacs-color-theme-solarized.
Commit Message
* gnu/packages/emacs-xyz (emacs-color-theme-solarized): New variable.
---
gnu/packages/emacs-xyz.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)
Comments
Hello,
Brian Kubisiak <brian@kubisiak.com> writes:
> * gnu/packages/emacs-xyz (emacs-color-theme-solarized): New variable.
Applied. Thank you.
Regards,
@@ -8283,6 +8283,39 @@ (define-public emacs-solarized-theme
package provides a light and a dark variant.")
(license license:gpl3+)))
+(define-public emacs-color-theme-solarized
+ ;; From 2017-10-24.
+ ;; No releases available.
+ (let ((commit "f3ca8902ea056fb8e46cb09f09c96294e31cd4ee") (revision "0"))
+ (package
+ (name "emacs-color-theme-solarized")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url
+ "https://github.com/sellout/emacs-color-theme-solarized")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16d7adqi07lzzr0qipl1fbag9l8kiyr3xrqxi528pimcisbg85d3"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ ;; these are intended for old versions of emacs and do not
+ ;; compile with emacs>=24
+ (add-before 'install 'remove-color-theme
+ (lambda _
+ (delete-file "./color-theme-solarized.el")
+ (delete-file "./color-theme-solarized-pkg.el"))))))
+ (home-page "https://github.com/sellout/emacs-color-theme-solarized")
+ (synopsis "Solarized Colorscheme for Emacs")
+ (description
+ "Emacs highlighting using Ethan Schoonover’s Solarized color scheme.")
+ (license license:expat))))
+
(define-public emacs-poet-theme
(let ((commit "16eb694f0755c04c4db98614d0eca1199fddad70")
(revision "1"))