@@ -122,6 +122,15 @@ across a broad spectrum of applications.")
(license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
"Some components have other similar licences."))))
+(define-public boost-cxx14
+ (package (inherit boost)
+ (arguments
+ (substitute-keyword-arguments (package-arguments boost)
+ ((#:make-flags flags)
+ `(append ,flags
+ '("cxxflags=-std=c++14")))))
+ (properties '((hidden? . #t)))))
+
(define-public boost-for-mysql
;; Older version for MySQL 5.7.23.
(package
@@ -2263,7 +2263,7 @@ single-member files which can't be decompressed in parallel.")
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ;; No tests available.
- (inputs `(("boost" ,boost)
+ (inputs `(("boost" ,boost-cxx14)
("libiconv" ,libiconv)
("xz" ,xz)))
(native-inputs `(("pkg-config" ,pkg-config)))
@@ -244,7 +244,7 @@ terminal using ncurses.")
"0m0mjb049sl62vx13h9waavysa30mk0rphacksnvf94n13la62v5"))))
(build-system gnu-build-system)
(inputs `(("libmpdclient" ,libmpdclient)
- ("boost" ,boost)
+ ("boost" ,boost-cxx14)
("readline" ,readline)
("ncurses" ,ncurses)
("taglib" ,taglib)