[bug#57456] gnu: Add neovim-packer.
Commit Message
---
This patch add neovim-packer, a neovim plugin manager to guix.
gnu/packages/vim.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)
Comments
Hello!
On Sun Aug 28, 2022 at 5:16 AM BST, gyara via Guix-patches via wrote:
> + (let ((commit "3a9f9801f683946b9f1047d8f4bf9946c29e927d")
> + (revision "1"))
Change to `0`, since this is the first revision in Guix.
> + (package
> + (name "neovim-packer")
> + (version (git-version "0.0.0" revision commit))
> + (home-page "https://github.com/wbthomason/packer.nvim")
Move this above `synopsis`.
> + (uri (git-reference
> + (url "https://github.com/wbthomason/packer.nvim.git")
Remove the `.git` part.
> + (arguments
> + '(#:install-plan '(("lua"
> + "share/nvim/site/pack/packer/start/packer.nvim/")
> + ("doc"
> + "share/nvim/site/pack/packer/start/packer.nvim/"))))
Probably better formatting:
(arguments
(list #:install-plan
#~'(("doc" "share/nvim/site/pack/guix/start/packer/")
("lua" "share/nvim/site/pack/guix/start/packer/"))))
(I used site/guix instead of site/packer for my own Guix
neovim packages; it seems like any name after site/ works.)
> + (synopsis "Neovim Plugin manager")
This might be better as:
Plugin manager for Neovim
> + (description
> + "A use-package inspired plugin manager for Neovim. Uses native packages,
> + supports Luarocks dependencies, written in Lua, allows for expressive config")
And this as:
This package provides a plugin manager for Neovim, inspired by Emacs's
@code{euse-package}. It's written in Lua, supports Luarocks dependencies,
and is based on Vim's builtin plugin support.
-- (
Thanks for your review!
Updated patch is followed.
--
存在するということは、自分を创造することだ。
After some test, I find that packer need to be place in
`pack/*/*/packer.nvim` because That plugin code relay on it.
--
存在するということは、自分を创造することだ。
@@ -639,6 +639,34 @@ (define-public editorconfig-vim
editors.")
(license license:bsd-2)))
+(define-public neovim-packer
+ (let ((commit "3a9f9801f683946b9f1047d8f4bf9946c29e927d")
+ (revision "1"))
+ (package
+ (name "neovim-packer")
+ (version (git-version "0.0.0" revision commit))
+ (home-page "https://github.com/wbthomason/packer.nvim")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/wbthomason/packer.nvim.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xn08z3a21mgfvp5i1nv57jnldwxwnl5nkryiff3zc99b1mizigp"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("lua"
+ "share/nvim/site/pack/packer/start/packer.nvim/")
+ ("doc"
+ "share/nvim/site/pack/packer/start/packer.nvim/"))))
+ (synopsis "Neovim Plugin manager")
+ (description
+ "A use-package inspired plugin manager for Neovim. Uses native packages,
+ supports Luarocks dependencies, written in Lua, allows for expressive config")
+ (license license:expat))))
+
(define-public neovim-syntastic
(package
(inherit vim-syntastic)