[bug#57348] gnu: Add eisl
Commit Message
This patch adds the Easy ISLisp interpreter/compiler for ISLisp to
lisp.scm
Best regards,
Joeke de Graaf
Comments
Hi,
Joeke <joeke@posteo.net> skribis:
> This patch adds the Easy ISLisp interpreter/compiler for ISLisp to
> lisp.scm
>
> [...]
>
> + (build-system gnu-build-system)
> + (native-inputs
> + (list gcc ncurses cppcheck))
Adding gcc to 'native-inputs' is not necessary, and ncurses should
probably be in 'inputs' instead of 'native-inputs'.
> + (arguments
> + `(#:modules
> + ((guix build utils)
> + (guix build gnu-build-system))
Specifying 'modules' here is not necessary.
>
> [...]
>
> + (home-page "https://github.com/sasagawa888/eisl")
> + (synopsis "Implementation of ISLisp")
> + (description "Easy ISLISP (eisl) is an implementation of ISLisp which
> +includes a compiler as well as an interpreter.")
> + (license license:bsd-2)))
It looks like some code in "cii/" is under the expat license, and some
code in "nana/" is under bsd-3, so they should be added to the 'license'
field.
Also, it looks like the files in "library/" are not compiled/installed.
Is it on purpose?
From ba1e8d927d081de4169d188c772adb2cdc79b57c Mon Sep 17 00:00:00 2001
From: Joeke de Graaf <joeke@posteo.net>
Date: Tue, 23 Aug 2022 00:45:40 +0200
Subject: [PATCH] gnu: Add eisl
---
gnu/packages/lisp.scm | 42 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 42 insertions(+)
@@ -21,6 +21,7 @@
;;; Copyright © 2021 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2021 Charles Jackson <charles.b.jackson@protonmail.com>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -59,6 +60,7 @@ (define-module (gnu packages lisp)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
#:use-module (gnu packages bdw-gc)
+ #:use-module (gnu packages check)
#:use-module (gnu packages compression)
#:use-module (gnu packages ed)
#:use-module (gnu packages fontutils)
@@ -1351,3 +1353,43 @@ (define-public buildapp
"Buildapp is an application for SBCL or CCL that configures and saves an
executable Common Lisp image. It is similar to cl-launch and hu.dwim.build.")
(license license:bsd-2)))
+
+
+(define-public eisl
+ (package
+ (name "eisl")
+ (version "2.60")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/sasagawa888/eisl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0qrmy6myyac38q3kf26axmxpmq9srhc6qy0ykfcsng50jzcdg1mn"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list gcc ncurses cppcheck))
+ (arguments
+ `(#:modules
+ ((guix build utils)
+ (guix build gnu-build-system))
+
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+ (string-append "CC=" ,(cc-for-target)))
+
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'create-store-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin")))
+ (mkdir-p out)
+ (mkdir-p bin))))
+ (delete 'configure))))
+ (home-page "https://github.com/sasagawa888/eisl")
+ (synopsis "Implementation of ISLisp")
+ (description "Easy ISLISP (eisl) is an implementation of ISLisp which
+includes a compiler as well as an interpreter.")
+ (license license:bsd-2)))
--
2.37.2