[bug#57234] Fix build of package icestorm
Commit Message
Hello!
I noticed icestorm doesn't build currently. I've attached a fix.
TIA for merging soon ;)
g
From de5b7f58c5c18621f69d15e11d78349c0d2d18be Mon Sep 17 00:00:00 2001
From: Gabriel Wicki <gabriel@erlikon.ch>
Date: Tue, 16 Aug 2022 01:46:07 +0200
Subject: [PATCH] gnu: fpga: Fix build of icestorm
* gnu/packages/fpga.scm (icestorm): Fix build.
[phases]{fix-build}: New phase.
---
gnu/packages/fpga.scm | 5 +++++
1 file changed, 5 insertions(+)
Comments
Gabriel Wicki <gabriel@erlikon.ch> writes:
> Hello!
>
> I noticed icestorm doesn't build currently. I've attached a fix.
>
> TIA for merging soon ;)
Hello, the latest version of icestorm have that fix, so I updated the
commit instead of merge this patch, thank you!
@@ -258,6 +258,11 @@ (define-public icestorm
(substitute* "icebox/icebox_vlog.py"
(("/usr/local/share") (string-append (assoc-ref outputs "out") "/share")))
#t))
+ (add-after 'fix-usr-local 'fix-build
+ (lambda _
+ (substitute* "icetime/icetime.cc"
+ (("#include <vector>")
+ "#include <vector>\n#include <stdexcept>"))))
(delete 'configure))))
(inputs
(list libftdi))