[bug#56599] gnu: fortune-mod: Remove off database.
Commit Message
* gnu/packages/games.scm (fortune-mod): Delete off database after install phase.
---
gnu/packages/games.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
Comments
Censorship is a tricky term, and it does not directly address why the
database is being removed. The phase should be more simply renamed to
remove-offensive-database, and include a comment on why the database is
being removed, referencing #54691.
@@ -7721,7 +7721,10 @@ (define-public fortune-mod
(lambda _
(with-directory-excursion #$output
(rename-file "games/fortune" "bin/fortune")
- (rmdir "games")))))))
+ (rmdir "games"))))
+ (add-after 'install 'commit-censorship
+ (lambda* (#:key outputs #:allow-other-keys)
+ (delete-file-recursively (string-append (assoc-ref outputs "out") "/share/fortunes/off/")))))))
(inputs (list recode))
(native-inputs
(list perl