[bug#56892] Fix the target detection fix.
Commit Message
Dear guix,
The NSIS target detection is still screwed up, but now with unicode!
This V2 fixes the fix.
Best regards,
Vivien
Comments
Vivien Kraus <vivien@planete-kraus.eu> writes:
> Dear guix,
>
> The NSIS target detection is still screwed up, but now with unicode!
>
> This V2 fixes the fix.
Pushed, thank you!
From 789aa3050cefe2dc508a3ecf672f9d00fb4fe0fb Mon Sep 17 00:00:00 2001
From: Vivien Kraus <vivien@planete-kraus.eu>
Date: Tue, 2 Aug 2022 17:23:05 +0200
Subject: [PATCH v2] gnu: nsis: Update to 3.08.
* gnu/packages/patches/nsis-source-date-epoch.patch: Drop this patch.
* gnu/packages/patches/nsis-env-passthru.patch: Adjust the patch.
* gnu/packages/installers.scm (make-nsis): Update to 3.08.
---
gnu/local.mk | 1 -
gnu/packages/installers.scm | 9 ++++----
gnu/packages/patches/nsis-env-passthru.patch | 17 +++++++-------
.../patches/nsis-source-date-epoch.patch | 23 -------------------
4 files changed, 12 insertions(+), 38 deletions(-)
delete mode 100644 gnu/packages/patches/nsis-source-date-epoch.patch
@@ -1550,7 +1550,6 @@ dist_patch_DATA = \
%D%/packages/patches/nginx-socket-cloexec.patch \
%D%/packages/patches/nnpack-system-libraries.patch \
%D%/packages/patches/nsis-env-passthru.patch \
- %D%/packages/patches/nsis-source-date-epoch.patch \
%D%/packages/patches/nss-getcwd-nonnull.patch \
%D%/packages/patches/nss-increase-test-timeout.patch \
%D%/packages/patches/nss-3.56-pkgconfig.patch \
@@ -34,16 +34,15 @@ (define (make-nsis machine target-arch nsis-target-type)
(xgcc (cross-gcc triplet #:libc xlibc)))
(package
(name (string-append "nsis-" machine))
- (version "3.05")
+ (version "3.08")
(source (origin
(method url-fetch)
(uri (string-append "http://prdownloads.sourceforge.net/nsis/nsis-"
version "-src.tar.bz2"))
(sha256
(base32
- "1sbwx5vzpddharkb7nj4q5z3i5fbg4lan63ng738cw4hmc4v7qdn"))
- (patches (search-patches "nsis-env-passthru.patch"
- "nsis-source-date-epoch.patch"))))
+ "11qy1n1qdcqwal9hn8cmzm7gxjdyx7by6w14rfz2l646afnp0lm8"))
+ (patches (search-patches "nsis-env-passthru.patch"))))
(build-system scons-build-system)
(native-inputs `(("xgcc" ,xgcc)
("xbinutils" ,xbinutils)
@@ -125,7 +124,7 @@ (define (mingw-path? path)
(lambda _
;; NSIS target detection is screwed up, manually change
;; it ourselves
- (substitute* "Source/build.cpp" (("m_target_type=TARGET_X86ANSI")
+ (substitute* "Source/build.cpp" (("m_target_type=TARGET_X86UNICODE")
(string-append "m_target_type=" ,nsis-target-type))))))))
(home-page "https://nsis.sourceforge.io/Main_Page")
(synopsis "System to create Windows installers")
@@ -1,12 +1,11 @@
---- nsis-3.04-src/SConstruct 2019-05-30 14:53:30.276775332 -0400
-+++ nsis-3.04-src/SConstruct 2019-05-30 14:54:17.901232914 -0400
-@@ -77,6 +77,9 @@
- if not toolset and not path:
- defenv = Environment(TARGET_ARCH = arch)
+--- nsis-3.08-src/SConstruct 2021-01-15 17:31:10.000000000 +0100
++++ nsis-3.08-src/SConstruct-passthru 2022-08-02 17:11:12.414702282 +0200
+@@ -71,7 +71,7 @@
-+import os;
-+defenv['ENV'] = os.environ
-+
- Export('defenv')
+ defenv = {
+ 'TARGET_ARCH': ARGUMENTS.get('TARGET_ARCH', 'x86'),
+- 'ENV': {}
++ 'ENV': os.environ.copy()
+ }
######################################################################
deleted file mode 100644
@@ -1,23 +0,0 @@
-Honour SOURCE_DATE_EPOCH for VERSION default
-
-Merged upstream as cd3f1024a37a332f1d4fa96a817ca80dfa2a478c, but not yet in a
-release. GitHub PR: https://github.com/kichik/nsis/pull/13
-
-Python snippet from: https://reproducible-builds.org/docs/source-date-epoch/#python
-
-
-diff --git a/SConstruct b/SConstruct
-index e8252c9..41786f2 100755
---- a/SConstruct
-+++ b/SConstruct
-@@ -95,8 +95,8 @@ default_doctype = 'html'
- if defenv.WhereIs('hhc', os.environ['PATH']):
- default_doctype = 'chm'
-
--from time import strftime, gmtime
--cvs_version = strftime('%d-%b-%Y.cvs', gmtime())
-+import time
-+cvs_version = time.strftime('%d-%b-%Y.cvs', time.gmtime(int(os.environ.get('SOURCE_DATE_EPOCH', time.time()))))
-
- opts = Variables()
-
base-commit: d5ba31c19accdf14bca23ebc0c3baf1c5b08fb5f
--
2.37.1