@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
@@ -62,7 +62,7 @@ version of this file."
(define set-utf8-locale
#~(begin
(setenv "LOCPATH"
- #$(file-append glibc-utf8-locales "/lib/locale/"
+ #+(file-append glibc-utf8-locales "/lib/locale/"
(version-major+minor
(package-version glibc-utf8-locales))))
(setlocale LC_ALL "en_US.utf8")))
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -217,7 +218,10 @@
(setenv "SHELL" (which "sh"))
#t))
(add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
+ (lambda* (#:key
+ inputs native-inputs
+ outputs
+ #:allow-other-keys)
;; Make sure the 'guix' command finds GnuTLS,
;; Guile-JSON, and Guile-Git automatically.
(let* ((out (assoc-ref outputs "out"))
@@ -230,7 +234,8 @@
"guile-bytestructures"))
(ssh (assoc-ref inputs "guile-ssh"))
(gnutls (assoc-ref inputs "gnutls"))
- (locales (assoc-ref inputs "glibc-utf8-locales"))
+ (locales (assoc-ref (or native-inputs inputs)
+ "glibc-utf8-locales"))
(deps (list gcrypt json sqlite gnutls
git bs ssh))
(effective
@@ -258,7 +263,8 @@
`("GUIX_LOCPATH" ":" suffix (,locpath)))
#t))))))
- (native-inputs `(("pkg-config" ,pkg-config)
+ (native-inputs `(("glibc-utf8-locales" ,glibc-utf8-locales)
+ ("pkg-config" ,pkg-config)
;; XXX: Keep the development inputs here even though
;; they're unnecessary, just so that 'guix environment
@@ -288,9 +294,7 @@
,@(if (and (not (%current-target-system))
(string=? (%current-system) "x86_64-linux"))
`(("boot-guile/i686" ,(bootstrap-guile-origin "i686-linux")))
- '())
-
- ("glibc-utf8-locales" ,glibc-utf8-locales)))
+ '())))
(propagated-inputs
`(("gnutls" ,gnutls)
("guile-gcrypt" ,guile-gcrypt)
@@ -6,7 +6,7 @@
;;; Copyright © 2016, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 David Craven <david@craven.ch>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2018, 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
@@ -1638,7 +1638,7 @@ archive' public keys, with GUIX."
;; file names such as 'nss-certs'. See
;; <https://bugs.gnu.org/32942>.
(string-append "GUIX_LOCPATH="
- #$glibc-utf8-locales "/lib/locale")
+ #+glibc-utf8-locales "/lib/locale")
"LC_ALL=en_US.utf8")
#:log-file #$log-file))
@@ -1774,7 +1774,7 @@ archive' public keys, with GUIX."
;; as 'nss-certs'. See <https://bugs.gnu.org/26948>.
#:environment-variables
(list (string-append "GUIX_LOCPATH="
- #$glibc-utf8-locales "/lib/locale")
+ #+glibc-utf8-locales "/lib/locale")
"LC_ALL=en_US.utf8")))
(stop #~(make-kill-destructor)))))))
@@ -8,6 +8,7 @@
;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;; Copyright © 2017 Huang Ying <huang.ying.caritas@gmail.com>
;;; Copyright © 2017 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1477,7 +1478,7 @@ are cross-built for TARGET."
;; install a UTF-8 locale.
#~(begin
(setenv "LOCPATH"
- #$(file-append glibc-utf8-locales "/lib/locale/"
+ #+(file-append glibc-utf8-locales "/lib/locale/"
(version-major+minor
(package-version glibc-utf8-locales))))
(setlocale LC_ALL "en_US.utf8")))
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -421,7 +422,7 @@ load path."
(string-append (if locpath
(string-append locpath ":")
"")
- #$(file-append glibc-utf8-locales
+ #+(file-append glibc-utf8-locales
"/lib/locale"))))
(let ((guix-main (module-ref (resolve-interface '(guix ui))