[bug#56775,2/4] gnu: rust-adler32-1: Update to 1.2.0.
Commit Message
* gnu/packages/crates-io.scm (rust-adler32-1): Update to 1.2.0.
---
gnu/packages/crates-io.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)
Comments
On 26-07-2022 09:26, Nicolas Graves via Guix-patches via wrote:
> + ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
> + ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
These will be automatically removedĀ by antioxidant, as Guix does not
support cross-compilation to wasm, so you don't need to include them
unless leaving them out causes build failures.
Greetings,
Maxime.
On Tue Jul 26, 2022 at 11:14 AM BST, Maxime Devos wrote:
>
> These will be automatically removed by antioxidant, as Guix does not
> support cross-compilation to wasm, so you don't need to include them
> unless leaving them out causes build failures.
>
> Greetings,
> Maxime.
It will cause build failures, because Cargo requires you to include all
dependencies, even the optional/unused ones.
-- (
On 26-07-2022 12:21, ( wrote:
> On Tue Jul 26, 2022 at 11:14 AM BST, Maxime Devos wrote:
>> These will be automatically removed by antioxidant, as Guix does not
>> support cross-compilation to wasm, so you don't need to include them
>> unless leaving them out causes build failures.
>>
>> Greetings,
>> Maxime.
> It will cause build failures, because Cargo requires you to include all
> dependencies, even the optional/unused ones.
This is true for some kind of dependencies (e.g., build-dependencies
IIRC) but not for other kind of dependencies (e.g. dependencies) IIRC. I
don't know which of them is the case for dev-dependencies.
Greetings,
Maxime.
On Tue Jul 26, 2022 at 11:47 AM BST, Maxime Devos wrote:
> This is true for some kind of dependencies (e.g., build-dependencies
> IIRC) but not for other kind of dependencies (e.g. dependencies) IIRC. I
> don't know which of them is the case for dev-dependencies.
That has not been the case in my experience; Cargo seems to want them all
to be provided.
-- (
Tested and it indeed fails
phase `patch-cargo-checksums' succeeded after 41.5 seconds
starting phase `build'
error: no matching package named `wasm-bindgen-test` found
location searched: registry `crates-io`
required by package `adler32 v1.2.0 (/tmp/guix-build-rust-adler32-1.2.0.drv-0/adler32-1.2.0)`
error: in phase 'build': uncaught exception:
%exception #<&invoke-error program: "cargo" arguments: ("build" "--release") exit-status: 101 term-signal: #f stop-signal: #f>
phase `build' failed after 0.2 seconds
Nicolas Graves via Guix-patches via <guix-patches@gnu.org> skriver:
> * gnu/packages/crates-io.scm (rust-adler32-1): Update to 1.2.0.
This causes a rebuild of 500+ packages through 'librsvg', so I pushed it
to the 'staging' branch in 7aad4a99f790e256ef03bcf4c6a619560ae48075.
@@ -1860,7 +1860,7 @@ (define-public rust-adler-0.2
(define-public rust-adler32-1
(package
(name "rust-adler32")
- (version "1.1.0")
+ (version "1.2.0")
(source
(origin
(method url-fetch)
@@ -1869,15 +1869,19 @@ (define-public rust-adler32-1
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0bgks405vz823bphgwhj4l9h6vpfh900s0phfk4qqijyh9xhfysn"))))
+ "0d7jq7jsjyhsgbhnfq5fvrlh9j0i9g1fqrl2735ibv5f75yjgqda"))))
(build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-compiler-builtins" ,rust-compiler-builtins-0.1)
("rust-rustc-std-workspace-core" ,rust-rustc-std-workspace-core-1))
#:cargo-development-inputs
- (("rust-bencher" ,rust-bencher-0.1)
- ("rust-rand" ,rust-rand-0.4))))
+ (("rust-criterion" ,rust-criterion-0.3)
+ ("rust-getrandom" ,rust-getrandom-0.1)
+ ("rust-humansize" ,rust-humansize-1)
+ ("rust-rand" ,rust-rand-0.7)
+ ("rust-wasm-bindgen" ,rust-wasm-bindgen-0.2)
+ ("rust-wasm-bindgen-test" ,rust-wasm-bindgen-test-0.3))))
(home-page "https://github.com/remram44/adler32-rs")
(synopsis "Implementation of the Adler32 rolling hash algorithm")
(description