[bug#56668] gnu: Add wavbreaker

Message ID 87r12gj8bt.fsf@bolo-santosi.mail-host-address-is-not-set
State New
Headers
Series [bug#56668] gnu: Add wavbreaker |

Commit Message

Joeke de Graaf July 20, 2022, 12:07 p.m. UTC
  Hello,

This patch adds the wavbreaker package to mp3.scm

Best regards,

Joeke de Graaf
  

Comments

Maxime Devos July 23, 2022, 7:50 p.m. UTC | #1
On 20-07-2022 14:07, Joeke de Graaf wrote:

> +    (native-inputs
> +     (list pkg-config cmake))
> +    (inputs (list glib gtk+ ao))

Please check that it works nicely (with, e.g., no missing icons, which 
sometimes happens for GTK+ stuff) in a pure environment. Try:

$ guix shell --pure wavbreaker -- 
insert-the-binary-name-here,probably-wavbreaker

If there are problems, we'll have to add some things to fix them.

Greetings,
Maxime.
  
Maxime Devos July 23, 2022, 7:51 p.m. UTC | #2
On 20-07-2022 14:07, Joeke de Graaf wrote:
> +    (license license:gpl2)))

Going by https://github.com/thp/wavbreaker/blob/master/src/appconfig.c, 
it's actually gpl2+, though I haven't verified whether that applies to 
all files.

Greetings,
Maxime.
  
Joeke de Graaf July 24, 2022, 6:07 p.m. UTC | #3
On 24.07.2022 12:31, ( wrote:
> On Sat Jul 23, 2022 at 11:14 PM BST, Joeke de Graaf wrote:
>> It seems that in the package's current state, it does not like being 
>> run
>> in a pure environment, it simply crashes.
>> The application seems to expect GTK icons to be in a certain place and
>> it's not finding them.
>> It's not immediately obvious to me what the solution for this is, but 
>> I
>> gather from your previous e-mail that this is a known and fixable
>> problem.
> 
> You should be able to fix this by adding the hicolor-icon-theme package
> to native-inputs.
> 
>     -- (

Thanks, this fixed it.
  
Joeke de Graaf July 24, 2022, 11:06 p.m. UTC | #4
Just an update on this issue to avoid duplicate effort if someone else 
also tries to fix this later:

On Maxime Devos' suggestion, I looked into glib-or-gtk-wrap.
Looking at %standard-phases in the module (guix build 
meson-build-system) there is already a glib-or-gtk-wrap phase.
Adding this phase manually after the install phase does not help to fix 
the problem (as expected, though it was worth a shot).

Later this week (hopefully tomorrow) I will try some more of Maxime 
Devos' suggestions


Best regards,

Joeke de Graaf
  

Patch

From 2f512eb8a85c4920aeea5f673129d1507f32cbb9 Mon Sep 17 00:00:00 2001
From: Joeke de Graaf <joeke@posteo.net>
Date: Wed, 20 Jul 2022 13:58:38 +0200
Subject: [PATCH] gnu: Add wavbreaker

---
 gnu/packages/mp3.scm | 32 +++++++++++++++++++++++++++++++-
 1 file changed, 31 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index 4a8bdad711..a3207ef062 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2021 Simon Streit <simon@netpanic.org>
 ;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Joeke de Graaf <joeke@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -50,13 +51,15 @@  (define-module (gnu packages mp3)
   #:use-module (gnu packages pulseaudio)
   #:use-module (gnu packages linux)               ;alsa-lib
   #:use-module (gnu packages video)               ;ffmpeg
+  #:use-module (gnu packages cmake)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix git-download)
   #:use-module (guix utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
-  #:use-module (guix build-system cmake))
+  #:use-module (guix build-system cmake)
+  #:use-module (guix build-system meson))
 
 (define-public libmad
   (package
@@ -710,3 +713,30 @@  (define-public python-pytaglib
 cross-platform, works with all Python versions, and is very
 simple to use yet fully featured.")
     (license license:gpl3)))
+
+(define-public wavbreaker
+  (package
+    (name "wavbreaker")
+    (version "0.15")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/thp/wavbreaker/")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32 "16h0sfcb8av6a368giizzwv9m0lq5c3bnf4b9vyyh9nkbbsc7c3j"))))
+    (build-system meson-build-system)
+    (native-inputs
+     (list pkg-config cmake))
+    (inputs (list glib gtk+ ao))
+    (home-page "https://wavbreaker.sourceforge.io/")
+    (synopsis "WAV and MP3 file splitter with a GUI")
+    (description
+     "Wavbreaker is a WAV and MP3 file splitter.  It can be used to
+break up a WAV or MP3 audio file into multiple WAV files.
+Wavbreaker contains a helpful waveform display of the audio file
+being edited, to help the user in splitting the file at the right
+point.  Wavbreaker also supports splitting MP3 files without
+re-encoding them, to preserve their original audio quality.")
+    (license license:gpl2)))
-- 
2.37.0