Message ID | 87k1gh1d6f.fsf@gmail.com |
---|---|
State | Accepted |
Headers | show |
Series | [bug#34959] Acknowledgement ([PATCH] Add Multiple Common Lisp Packages) | expand |
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes: > Phew! I hope I did this right because that was a lot of work to get > those in shape! ;p With some minor issues (lack commit messages, and some patches are out of order etc.) fixed, I push them all, thank you!! > > I've at least learned more about Guix packaging :) Welcome :-)
iyzsong@member.fsf.org (宋文武) writes: > Katherine Cox-Buday <cox.katherine.e@gmail.com> writes: > >> Phew! I hope I did this right because that was a lot of work to get >> those in shape! ;p > > With some minor issues (lack commit messages, and some patches are out > of order etc.) fixed, I push them all, thank you!! > >> >> I've at least learned more about Guix packaging :) > > Welcome :-) Thanks very much for fixing these things up and landing! I continue to have great experiences with devs in the Guix community, and it encourages me to keep contributing :) Do all commits require message bodies?
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes:
> Do all commits require message bodies?
Yes, for better or worse we adhere to the GNU conventions in commit
messages. Since the format is predictable and can be, in part, derived
from the changes we offer Emacs snippets that can be used to generate
the commit messages more quickly.
If you’re using Emacs and Magit you only need to type “add” or “update”
and hit TAB to have the commit message generated for you.
(If you’re not using Emacs we would welcome snippets for other editors
to make it writing commit messages easier.)
--
Ricardo
Ricardo Wurmus <rekado@elephly.net> writes: > Katherine Cox-Buday <cox.katherine.e@gmail.com> writes: > >> Do all commits require message bodies? > > Yes, for better or worse we adhere to the GNU conventions in commit > messages. Since the format is predictable and can be, in part, derived > from the changes we offer Emacs snippets that can be used to generate > the commit messages more quickly. > > If you’re using Emacs and Magit you only need to type “add” or “update” > and hit TAB to have the commit message generated for you. > > (If you’re not using Emacs we would welcome snippets for other editors > to make it writing commit messages easier.) > > -- > Ricardo I am indeed using emacs and magit, so I'll start doing this. As an aside, I don't know how much of this is obvious to other folks (i.e. maybe folks who contribute to GNU projects more often), but I feel like I've been discovering things like this which aren't in the Guix manual. Did I just miss this stuff (very possible!), or are we missing some instruction and perhaps links to GNU standards?
Katherine Cox-Buday <cox.katherine.e@gmail.com> writes: > As an aside, I don't know how much of this is obvious to other folks > (i.e. maybe folks who contribute to GNU projects more often), but I feel > like I've been discovering things like this which aren't in the Guix > manual. Did I just miss this stuff (very possible!), or are we missing > some instruction and perhaps links to GNU standards? The “Contributing” section in the manual does link to the GNU standards (if you’re reading this in an Info reader like Emacs you may want to install the “gnu-standards” package to be able to follow the link locally). It also mentions the snippets and how to use them. The Contributing section in the manual is pretty big, so it’s easy to miss something. -- Ricardo
From 1983505f62c0df61ac8f780fd8d3394c953a4612 Mon Sep 17 00:00:00 2001 From: Katherine Cox-Buday <cox.katherine.e@gmail.com> Date: Fri, 29 Mar 2019 16:34:36 -0500 Subject: [PATCH 42/42] gnu: Add clack --- gnu/packages/lisp.scm | 30 ++++++++++++++++++++++++++++++ 1 file changed, 30 insertions(+) diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm index 07ec2efa12..a4acd50712 100644 --- a/gnu/packages/lisp.scm +++ b/gnu/packages/lisp.scm @@ -5170,3 +5170,33 @@ mime-type of a file.") (define-public cl-trivial-mimes (sbcl-package->cl-source-package sbcl-trivial-mimes)) +(define-public sbcl-clack + (let ((commit "e3e032843bb1220ab96263c411aa7f2feb4746e0") + (revision "1")) + (package + (name "sbcl-clack") + (version (git-version "2.0.0" revision commit)) + (source + (origin + (method git-fetch) + (uri (git-reference + (url "https://github.com/fukamachi/clack.git") + (commit commit))) + (sha256 + (base32 "1ymzs6qyrwhlj6cgqsnpyn6g5cbp7a3s1vgxwna20y2q7y4iacy0")))) + (build-system asdf-build-system/sbcl) + (inputs + `(("sbcl-lack" ,sbcl-lack) + ("sbcl-lack-middleware-backtrace" ,sbcl-lack-middleware-backtrace) + ("sbcl-bordeaux-threads" ,sbcl-bordeaux-threads))) + (home-page "https://github.com/fukamachi/clack") + (synopsis + "Clack is a web application environment for Common Lisp inspired by +Python's WSGI and Ruby's Rack.") + (description + "Clack is a web application environment for Common Lisp inspired by +Python's WSGI and Ruby's Rack.") + (license license:llgpl)))) + +(define-public cl-clack + (sbcl-package->cl-source-package sbcl-clack)) -- 2.20.1